summaryrefslogtreecommitdiff
path: root/dev-ruby/daemon_controller/daemon_controller-1.2.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /dev-ruby/daemon_controller/daemon_controller-1.2.0-r2.ebuild
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'dev-ruby/daemon_controller/daemon_controller-1.2.0-r2.ebuild')
-rw-r--r--dev-ruby/daemon_controller/daemon_controller-1.2.0-r2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/daemon_controller/daemon_controller-1.2.0-r2.ebuild b/dev-ruby/daemon_controller/daemon_controller-1.2.0-r2.ebuild
new file mode 100644
index 000000000000..538b16a1b408
--- /dev/null
+++ b/dev-ruby/daemon_controller/daemon_controller-1.2.0-r2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Library to start and stop specific daemons programmatically in a robust manner"
+HOMEPAGE="https://github.com/FooBarWidget/daemon_controller"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ # fix tests with RSpec 2
+ sed -i -e '1irequire "thread"' spec/test_helper.rb || die
+}