summaryrefslogtreecommitdiff
path: root/dev-ruby/curb
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-11-03 06:47:15 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-11-03 06:47:15 +0000
commitfc2f1018fc323ef2c6572734a9b130427cba76a6 (patch)
treef834bdc9a67923ce75297c09d00d1e7b90791d26 /dev-ruby/curb
parent162945d2a91899b637bbb9e163b406350de12906 (diff)
gentoo resync : 03.11.2021
Diffstat (limited to 'dev-ruby/curb')
-rw-r--r--dev-ruby/curb/Manifest1
-rw-r--r--dev-ruby/curb/curb-0.9.11.ebuild49
2 files changed, 0 insertions, 50 deletions
diff --git a/dev-ruby/curb/Manifest b/dev-ruby/curb/Manifest
index 0468362babc4..7a419f01d1e3 100644
--- a/dev-ruby/curb/Manifest
+++ b/dev-ruby/curb/Manifest
@@ -1,4 +1,3 @@
DIST curb-0.9.11.gem 88576 BLAKE2B 1656a17070151ddd1bd63c3e23885d36d8e2b133b19e00347892363a9a20c88baa10932ceb5273733b18847d8d19dc403aa4b7f36fbd80c8dde126ae46743796 SHA512 000ee2054a5866de09042dfc5894330900e401aa94a0fe8bb133fe9c661f7899992adff0585e5ed3725d3564cd9819d76653655f3539faaa61ca6acabe3a8602
EBUILD curb-0.9.11-r1.ebuild 1391 BLAKE2B 462de9fb6407457864bd56b2a0de59bb4723da435455b1371b2df8acd349e4a6424909897521e0a0dd7fd75520af11346bfc3193cd572247d64beca032a7ed2b SHA512 59706c93edaada27f54a15cc8ec7735b28d05a7d2736dbf0b00bf15b5502850466fb45b0278c735655493b5128e0813bc80b0cea2253541434b8611733deb222
-EBUILD curb-0.9.11.ebuild 1351 BLAKE2B 482f6136e62728fd90f1b312fbd4fa59c2c005aa0380480700b77574020a6c92197843f56ad915d557a1666aadababd4723c620d5909b80d285fc0eb7533d4bf SHA512 065dcc8ceaab26c8227a47cf63cd0a4d630c2e69fe2e1f0eaa7a6f708fb38bb30a68c265b130225b3a8511d30c22d00db85747cff4901794c1ee633ec2778063
MISC metadata.xml 336 BLAKE2B fd9820c5561af2381bf081eb2f3370727020edc79f306bd94b90699e8a817d218edb11ccc60ae9aa43f1713218a91c9b53cff0a6c23fc3d189e06bc5a1265b71 SHA512 f948d0e7f36c4b9912c58d6a7bf1b2ac5934075780fc7de3d6f759276e4ee297850f725259c06245affca40745bdc2bab0ab78bbd60b308a5d11fc97edeb4ac1
diff --git a/dev-ruby/curb/curb-0.9.11.ebuild b/dev-ruby/curb/curb-0.9.11.ebuild
deleted file mode 100644
index 07ac269e3ecf..000000000000
--- a/dev-ruby/curb/curb-0.9.11.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-USE_RUBY="ruby25 ruby26 ruby27"
-
-RUBY_FAKEGEM_RECIPE_TEST="rake"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Ruby-language bindings for libcurl"
-HOMEPAGE="https://github.com/taf2/curb"
-
-LICENSE="Ruby"
-SLOT="0"
-KEYWORDS="amd64"
-IUSE=""
-
-DEPEND+=" net-misc/curl[ssl]"
-RDEPEND+=" net-misc/curl[ssl]"
-
-all_ruby_prepare() {
- # fix tests when localhost is also ::1
- sed -i -e 's|localhost:|127.0.0.1:|g' tests/*.rb || die
-
- # avoid tests making outside network connections
- rm tests/bug_postfields_crash.rb || die
- sed -e '/test_easy_http_verbs_must_respond_to_str/,/^ end/ s:^:#:' \
- -i tests/tc_curl_easy.rb || die
- sed -e '/test_connection_keepalive/aomit "network connection needed"' \
- -i tests/tc_curl_multi.rb || die
-
- # Fix test that expects wrong output
- sed -i -e 's/200 OK /200 OK/' tests/tc_curl_easy.rb || die
-
- # avoid failing tests where failure condition seems weird, no
- # upstream travis so not clear if the test is indeed broken.
- sed -i -e '/test_multi_easy_http/,/^ end/ s:^:#:' tests/tc_curl_multi.rb || die
-}
-
-each_ruby_configure() {
- ${RUBY} -Cext extconf.rb || die "extconf.rb failed"
-}
-
-each_ruby_compile() {
- emake -Cext CFLAGS="${CFLAGS} -fPIC" archflags="${LDFLAGS}" V=1
- cp -l ext/curb_core$(get_modname) lib || die
-}