summaryrefslogtreecommitdiff
path: root/dev-ruby/console/console-1.23.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-20 12:05:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-20 12:05:24 +0100
commitda7ae1dd1fccb6b3c0e4763ab983ad96d57bf463 (patch)
tree0a7a1b7b3ad60c3b21c697e75908b256fc9ed6b1 /dev-ruby/console/console-1.23.7.ebuild
parentb6cfc0c19effe2d9f7b8ab303cd00636f16da253 (diff)
gentoo auto-resync : 20:04:2024 - 12:05:23
Diffstat (limited to 'dev-ruby/console/console-1.23.7.ebuild')
-rw-r--r--dev-ruby/console/console-1.23.7.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ruby/console/console-1.23.7.ebuild b/dev-ruby/console/console-1.23.7.ebuild
new file mode 100644
index 000000000000..3ddf1603f2f0
--- /dev/null
+++ b/dev-ruby/console/console-1.23.7.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_EXTRADOC="readme.md"
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+RUBY_FAKEGEM_RECIPE_TEST="sus"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Beautiful logging for Ruby"
+HOMEPAGE="https://github.com/socketry/console"
+SRC_URI="https://github.com/socketry/console/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+ruby_add_rdepend "
+ dev-ruby/fiber-annotation
+ dev-ruby/fiber-local
+ dev-ruby/json
+"
+
+all_ruby_prepare() {
+ sed -i -E 's/require_relative "(.+)"/require File.expand_path("\1")/g' "${RUBY_FAKEGEM_GEMSPEC}" || die
+
+ # Avoid dependency on covered.
+ rm -f config/sus.rb || die
+
+ # Avoid sandbox violation during tests
+ sed -i -e 's:/tmp/:'"${TMPDIR}"'/:' test/console/output.rb || die
+}