summaryrefslogtreecommitdiff
path: root/dev-ruby/console/console-1.17.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-26 07:31:54 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-26 07:31:54 +0100
commitf935e23b9515ca0a4f338a1a57ff12e21b0c6b0a (patch)
treef0652279e40bba2231437f7630e85dfdad0b0ca1 /dev-ruby/console/console-1.17.2.ebuild
parentd2b7cca519cd1aa575ebbc562c57071266ae63f1 (diff)
gentoo auto-resync : 26:06:2023 - 07:31:54
Diffstat (limited to 'dev-ruby/console/console-1.17.2.ebuild')
-rw-r--r--dev-ruby/console/console-1.17.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ruby/console/console-1.17.2.ebuild b/dev-ruby/console/console-1.17.2.ebuild
new file mode 100644
index 000000000000..6a8c6a91b3c3
--- /dev/null
+++ b/dev-ruby/console/console-1.17.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="readme.md"
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+RUBY_FAKEGEM_RECIPE_TEST="sus"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Beautiful logging for Ruby"
+HOMEPAGE="https://github.com/socketry/console"
+SRC_URI="https://github.com/socketry/console/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ dev-ruby/fiber-annotation
+ dev-ruby/fiber-local
+"
+
+all_ruby_prepare() {
+ sed -i -E 's/require_relative "(.+)"/require File.expand_path("\1")/g' "${RUBY_FAKEGEM_GEMSPEC}" || die
+
+ # Avoid dependency on covered.
+ rm -f config/sus.rb || die
+
+ # Avoid sandbox violation during tests
+ sed -i -e 's:/tmp/:'"${TMPDIR}"'/:' test/console/output.rb || die
+}