summaryrefslogtreecommitdiff
path: root/dev-ruby/connection_pool
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/connection_pool
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/connection_pool')
-rw-r--r--dev-ruby/connection_pool/Manifest5
-rw-r--r--dev-ruby/connection_pool/connection_pool-2.2.1.ebuild27
-rw-r--r--dev-ruby/connection_pool/connection_pool-2.2.2.ebuild27
-rw-r--r--dev-ruby/connection_pool/metadata.xml11
4 files changed, 70 insertions, 0 deletions
diff --git a/dev-ruby/connection_pool/Manifest b/dev-ruby/connection_pool/Manifest
new file mode 100644
index 000000000000..1e69a6312cab
--- /dev/null
+++ b/dev-ruby/connection_pool/Manifest
@@ -0,0 +1,5 @@
+DIST connection_pool-2.2.1.gem 13824 BLAKE2B 2328a86f9d625d245f3e74d41fd615d95ea68a6fb8b1d17a9a0f9dc4ff8b772eb2942fd9103b12875a4ea2f3b6d922227a4da79fc61bd348d4bae5aa50b442a2 SHA512 74167b200fcc02d3a60fdc0e71b44c80f1c72db75b5f604a442bd5fb55138fe1750a2db095e0283104fda35fd9024cb71c7ddb614c3d472f814d686b686b6ef0
+DIST connection_pool-2.2.2.gem 13824 BLAKE2B 2f52bb3451dec5916d5797596f7bc3dbf39845321ee83736d679c433e96f154db852469b1f6d0d3b7c7f48262f7840087d89cdd40ece22b67a29c20ff77274dd SHA512 74cb64aa3f183ee4e41f438133f60581e9f99a1d5b5daf61607cff2329bfb1fbd8810d87c35d709418a22ad925049e3e9403a602107452414a67aee1c6eecfe9
+EBUILD connection_pool-2.2.1.ebuild 735 BLAKE2B 1efc20a9184b374fce25b62928a1aedd3ad6cde7ee066507d5c8c98293973abc99658d5ff9621c97c6da8dfa0ad6e93e675977950e3a86096fc43b814bca47d5 SHA512 245fc30a43eade01a1f72701a7f55ad33c98d92a0dd43018289f7ef6ff511818ff3490e2560bb64e0952a2acf864737bd8ede8566fa3185e2f5ee11d222a7763
+EBUILD connection_pool-2.2.2.ebuild 729 BLAKE2B 4e6937573dfd1fa17d4bf7e7ccf17eab67a0d3a6e69a980ef539aed26eff70684680de678f5aeee7b677f51783e9620494fa8372e36ed7890dc21febed675695 SHA512 9c641bdadafbc297c7f7fabb0589ab45ff9a02198002ab27401c64cd313bcc2cecef6b56f7ecdbf5b3c190274f423a08f930c5aba4023e77ad0c53b7f08408a6
+MISC metadata.xml 349 BLAKE2B 7ffc13174f2f47522a66c48922952798d03fbbb15419d9a52e183c633b56d863e85fab4682420aa9fffeb16d474f52de30799489a99221f25438524dbc569303 SHA512 18245f101f862c5880a42121eac9947a22fac206823d85ba650f5766af334208a64f97e7ea44e298f4f3c1191eb6bbf0e37949974c737060dd66434e1963b41c
diff --git a/dev-ruby/connection_pool/connection_pool-2.2.1.ebuild b/dev-ruby/connection_pool/connection_pool-2.2.1.ebuild
new file mode 100644
index 000000000000..030165fd8fae
--- /dev/null
+++ b/dev-ruby/connection_pool/connection_pool-2.2.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_TEST="rake"
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="Changes.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Generic connection pooling for Ruby"
+HOMEPAGE="https://github.com/mperham/connection_pool"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( >=dev-ruby/minitest-5 )"
+
+all_ruby_prepare() {
+ sed -i -e '/git ls-files/d' connection_pool.gemspec || die
+ sed -i -e '/bundler/d' Rakefile || die
+ sed -i -e "s/gem 'minitest'/gem 'minitest', '~> 5.0'/" test/helper.rb || die
+}
diff --git a/dev-ruby/connection_pool/connection_pool-2.2.2.ebuild b/dev-ruby/connection_pool/connection_pool-2.2.2.ebuild
new file mode 100644
index 000000000000..97a8f019f2a1
--- /dev/null
+++ b/dev-ruby/connection_pool/connection_pool-2.2.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_TEST="rake"
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="Changes.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Generic connection pooling for Ruby"
+HOMEPAGE="https://github.com/mperham/connection_pool"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( >=dev-ruby/minitest-5 )"
+
+all_ruby_prepare() {
+ sed -i -e '/git ls-files/d' connection_pool.gemspec || die
+ sed -i -e '/bundler/d' Rakefile || die
+ sed -i -e "s/gem 'minitest'/gem 'minitest', '~> 5.0'/" test/helper.rb || die
+}
diff --git a/dev-ruby/connection_pool/metadata.xml b/dev-ruby/connection_pool/metadata.xml
new file mode 100644
index 000000000000..f7170698a4f1
--- /dev/null
+++ b/dev-ruby/connection_pool/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">mperham/connection_pool</remote-id>
+ </upstream>
+</pkgmetadata>