summaryrefslogtreecommitdiff
path: root/dev-ruby/compass/compass-1.0.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/compass/compass-1.0.3-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/compass/compass-1.0.3-r1.ebuild')
-rw-r--r--dev-ruby/compass/compass-1.0.3-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-ruby/compass/compass-1.0.3-r1.ebuild b/dev-ruby/compass/compass-1.0.3-r1.ebuild
new file mode 100644
index 000000000000..cc402da8bb91
--- /dev/null
+++ b/dev-ruby/compass/compass-1.0.3-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_TASK_TEST="-Ilib test features"
+
+RUBY_FAKEGEM_EXTRAINSTALL="VERSION VERSION_NAME"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Compass Stylesheet Authoring Framework"
+HOMEPAGE="http://compass-style.org/"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="~amd64"
+IUSE=""
+
+# Gem does not contain all files needed to run specs and it is not clear
+# which upstream repository/branch/directory to use.
+RESTRICT="test"
+
+ruby_add_rdepend ">=dev-ruby/chunky_png-1.2
+ >=dev-ruby/compass-core-1.0.2:1.0
+ >=dev-ruby/compass-import-once-1.0.5:1.0
+ >=dev-ruby/rb-inotify-0.9
+ >=dev-ruby/sass-3.3.13:* <dev-ruby/sass-3.5:*
+ !!<dev-ruby/compass-0.12.7-r1"
+
+#ruby_add_bdepend "test? ( dev-ruby/colorize )"
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/ s:^:#:' Rakefile || die
+
+ # Remove rb-fsevent dependency since it is not needed on Linux and
+ # not packaged.
+ sed -i -e '/rb-fsevent/,/^-/ s:^:#:' ../metadata || die
+}