summaryrefslogtreecommitdiff
path: root/dev-ruby/compass-import-once/compass-import-once-1.0.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ruby/compass-import-once/compass-import-once-1.0.5.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ruby/compass-import-once/compass-import-once-1.0.5.ebuild')
-rw-r--r--dev-ruby/compass-import-once/compass-import-once-1.0.5.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/compass-import-once/compass-import-once-1.0.5.ebuild b/dev-ruby/compass-import-once/compass-import-once-1.0.5.ebuild
new file mode 100644
index 000000000000..bab268b2e693
--- /dev/null
+++ b/dev-ruby/compass-import-once/compass-import-once-1.0.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23"
+
+# Skip tests since they depend on sass-globbing which does not have a
+# license and where the last version is known to be broken.
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="VERSION"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Speed up your Sass compilation by making @import only import each file once"
+HOMEPAGE="http://compass-style.org/"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/sass-3.2:* <dev-ruby/sass-3.5:*
+"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/I s:^:#:' Rakefile || die
+}