summaryrefslogtreecommitdiff
path: root/dev-ruby/commonmarker/commonmarker-0.23.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-25 14:07:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-25 14:07:44 +0000
commit6a84e414622fd99c22318ce656a77bb2a0433fc7 (patch)
tree048f41d4a2a9c373e50bf0906c5508e6f5104fae /dev-ruby/commonmarker/commonmarker-0.23.7.ebuild
parenta1b20429e7e2ba1b44414459afd5a2b50788cd9c (diff)
gentoo auto-resync : 25:01:2023 - 14:07:44
Diffstat (limited to 'dev-ruby/commonmarker/commonmarker-0.23.7.ebuild')
-rw-r--r--dev-ruby/commonmarker/commonmarker-0.23.7.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-ruby/commonmarker/commonmarker-0.23.7.ebuild b/dev-ruby/commonmarker/commonmarker-0.23.7.ebuild
new file mode 100644
index 000000000000..32c52aa7af3b
--- /dev/null
+++ b/dev-ruby/commonmarker/commonmarker-0.23.7.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/commonmarker/extconf.rb)
+RUBY_FAKEGEM_EXTENSION_LIBDIR="lib/commonmarker"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="commonmarker.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A fast, safe, extensible parser for CommonMark, wrapping the libcmark library"
+HOMEPAGE="https://github.com/gjtorikian/commonmarker"
+SRC_URI="https://github.com/gjtorikian/commonmarker/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64"
+IUSE=""
+
+# app-text/cmark is bundled in a modified way and integrated with the gem code
+
+all_ruby_prepare() {
+ sed -i -e '/focus/ s:^:#:' test/test_helper.rb || die
+
+ # Avoid tests depending on unbundled cmark specification files
+ rm -f test/test_{spec,smartpunct}.rb || die
+
+}
+
+each_ruby_prepare() {
+ # Use current ruby version
+ sed -i -e '/make_bin/,/end/ s:ruby:'${RUBY}':' test/test_helper.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test:. -e 'Dir["test/test_*.rb"].each {|f| require f}' || die
+}