summaryrefslogtreecommitdiff
path: root/dev-ruby/commander
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-03 00:07:26 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-03 00:07:26 +0100
commita3bb28551df94028000fb72308a9e9baa01458b0 (patch)
tree33b14c7bf0dffbd5bb04dbd5b395514ebdda4896 /dev-ruby/commander
parent6657c680376cedf378fcf328e5fa03ed3b41d580 (diff)
gentoo auto-resync : 03:06:2024 - 00:07:25
Diffstat (limited to 'dev-ruby/commander')
-rw-r--r--dev-ruby/commander/Manifest3
-rw-r--r--dev-ruby/commander/commander-4.6.0-r1.ebuild25
-rw-r--r--dev-ruby/commander/commander-5.0.0.ebuild27
3 files changed, 55 insertions, 0 deletions
diff --git a/dev-ruby/commander/Manifest b/dev-ruby/commander/Manifest
index 4681bf6d4e36..8d86c6862117 100644
--- a/dev-ruby/commander/Manifest
+++ b/dev-ruby/commander/Manifest
@@ -1,3 +1,6 @@
DIST commander-4.6.0.gem 38400 BLAKE2B c4adf5b58fe679378012a893526cb00ee71c4cda5686d397ee93aeb11dcf1b32a4aa8c4e6b77c2ed07af75bf2492da65591cf49b2e05a658e753e78a9a12736a SHA512 01e7d4076b6ff632f6852e15bf995033034a71d6320c5b3b41751e86894f5eca35b408311e757c555334d220a9a811a0d60c0fc993414961f1050d948cb9f5c7
+DIST commander-5.0.0.gem 38400 BLAKE2B 702721d8a2565949d84fe8610139d507b966054c322f7badfdd433a49ffcc03a9de51a7c014bd49def313035c7dd4563c8f6673b5225eb42facb776e1502167d SHA512 32f621c2fb9c8b167b6595b1ca7f1a056c089ad6ffdcdcce77db7a19c60bc44910501c41f33a29bdce45c90aa9feeebc596d822ed57efe47301499d5d30b32a1
+EBUILD commander-4.6.0-r1.ebuild 582 BLAKE2B c96d990cfd4792a1292a05ad439a8e864d191cac2c9b13aa4596a46c4ca8b84b9abf56abdbc5e51eb6398208e7ef97de599b641b83833fc8e61838c27e087106 SHA512 41d903d4adfe40c3bccfc58df0c5052d3c33fcb8e4071b2e89d1b082d3cc747a41a627f14a4ecffe92363f11d63a4d8f9f55572ff733c196337833965e064d01
EBUILD commander-4.6.0.ebuild 558 BLAKE2B 7bfcda7e26fee70c51b401f04669f9470bbde2131693b8eb623ff7dab44d4dc05cdaf7022be039a8875e04456982ebe3b14e59fa361731dbf8810a2726d75cb5 SHA512 84646d03c4be5caa484f9140bcfa5e388d2fe64ccfd890dd39e737a0077b740e2e0e4a875f590465a820ceec2c8b7407d489a800c23ef32684ef9433fff18345
+EBUILD commander-5.0.0.ebuild 587 BLAKE2B 862ab9b43f520bf073a75e03c68e9a79bb2680629d7e76d0179866d0f6adac1aca8b4ceaee811102ba8c4d93f8df23453624f77428aad22478ba0dc8db0182fa SHA512 7afa3e283fa3f043ad50edcfacb82f0212190083fbfc4fdeca91d2a69774acef481a62f6881e9587b8aa650e4570b1b48514235afc8b119c328ff2c9be263637
MISC metadata.xml 332 BLAKE2B 33d94ec108895d3ece155fa04ec33410f0e5c3fd165f195e2febf2e5821de50bd188e8bf6985db978dc6c52597f2f416afda1757fc334ad750c44c72e491eee4 SHA512 7dc460d149051207704ca238c210058e6fbb42effcf0efbf92f42c2bc2ccc98bc15ed2267d2b3009870664a5e6d2e99d10c8baee39d19c79a8ed214c65893ba4
diff --git a/dev-ruby/commander/commander-4.6.0-r1.ebuild b/dev-ruby/commander/commander-4.6.0-r1.ebuild
new file mode 100644
index 000000000000..a264001ce01e
--- /dev/null
+++ b/dev-ruby/commander/commander-4.6.0-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRADOC="History.rdoc README.md"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="The complete solution for Ruby command-line executables"
+HOMEPAGE="https://github.com/commander-rb/commander"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/highline:2"
+
+all_ruby_prepare() {
+ sed -i -e "/simplecov/,/end/ s:^:#:" spec/spec_helper.rb || die
+}
diff --git a/dev-ruby/commander/commander-5.0.0.ebuild b/dev-ruby/commander/commander-5.0.0.ebuild
new file mode 100644
index 000000000000..331471d9b141
--- /dev/null
+++ b/dev-ruby/commander/commander-5.0.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_EXTRADOC="History.rdoc README.md"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="The complete solution for Ruby command-line executables"
+HOMEPAGE="https://github.com/commander-rb/commander"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ !<dev-ruby/commander-4.6.0-r1:0
+ dev-ruby/highline:3
+"
+
+all_ruby_prepare() {
+ sed -i -e "/simplecov/,/end/ s:^:#:" spec/spec_helper.rb || die
+}