summaryrefslogtreecommitdiff
path: root/dev-ruby/coderay
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /dev-ruby/coderay
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'dev-ruby/coderay')
-rw-r--r--dev-ruby/coderay/Manifest1
-rw-r--r--dev-ruby/coderay/coderay-1.1.3-r2.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-ruby/coderay/Manifest b/dev-ruby/coderay/Manifest
index 256ec9f81a11..446580da9774 100644
--- a/dev-ruby/coderay/Manifest
+++ b/dev-ruby/coderay/Manifest
@@ -3,4 +3,5 @@ DIST coderay-1.1.2.tar.gz 220645 BLAKE2B 85405da2b148ae23573abf2c3fcf94a64302475
DIST coderay-1.1.3.tar.gz 229139 BLAKE2B a900cc5fbac950f66814d9300876d6a273b296d07139297d5344d26c5710d23c37761e5743ef972f523afa20fa663f239c03d9d2ad47232b77e53fe5053736f0 SHA512 a5208965e8dbad53d179fdc1c57df59ba4e13522a1a57c371ccd3f9369408a1c7d878867df48b201a1d590b46ef0f9bada3f3e7810866f17d244b5b370aba3fb
EBUILD coderay-1.1.2.ebuild 1349 BLAKE2B ab08112a58cdadd308cb89a58a2f9260155c7648e1550a1aa796a62a78bfcf94e0343f8141d558648bad5267f257c397ae7623030c87f935425d89ba10134fee SHA512 d5b4745f057ced13541c0e48b23fb134e25d1e9025c26824f5bf509935e28ae425f8b43f21857f21b1188c347a1b6e31adbce47a72605cabcf86e6450eaf060d
EBUILD coderay-1.1.3-r1.ebuild 1586 BLAKE2B fc31fc4399b03d75ca56d5f7d613a0b2759a71a38077b5ed79451e71996c3cdc6ddc5f5c5224491af3495f8219b31b749ad8440ff0b55ce3256ae17678abbc6f SHA512 56366ceae810f66ec5101aea12416eeb5aedefbb548e9ef1de74cf131eb4bed9e4a87cc4d3154388204ed00615408607780b54ca727290e49a877904fe61833b
+EBUILD coderay-1.1.3-r2.ebuild 1586 BLAKE2B b8828c3e8e183f1af3c7ab9a0951480d3aba81935f3b4b7aa543cfa395c496305df83fd2040021d8880deb1be2b26cf62b8f5ddfd7c1e393ee7c925a2e387628 SHA512 102feafdc8b80ca053dbe25c8259e364123a48a11b7ca647c56a4d5d0dc7b41d68bafdffece0efe57ff98bcd103485db3710c4cc599e677ebe0745a96b9d6359
MISC metadata.xml 343 BLAKE2B ab708c520474d5d977634451ec6b6ef75398273f4197e7e9b3e825056e88a0f8ac9394ed996be392a74493993512e2e52a271e3aa2f10dc75d8d789b543f183a SHA512 38231f059928acbe3e8881885133c2ddb54b004ad3323e8c95f1d663f0592dca4890aa0065bfc1abd94c7039f26e7effeaa7fd1d0673726c30b86f188d8c7139
diff --git a/dev-ruby/coderay/coderay-1.1.3-r2.ebuild b/dev-ruby/coderay/coderay-1.1.3-r2.ebuild
new file mode 100644
index 000000000000..e02963145021
--- /dev/null
+++ b/dev-ruby/coderay/coderay-1.1.3-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+
+# The test target also contains test:exe but that requires
+# shoulda-context which we do not have packaged yet.
+RUBY_FAKEGEM_TASK_TEST="spec test:functional test:units"
+
+RUBY_FAKEGEM_TASK_DOC="doc"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRADOC="Changes-pre-1.0.textile Changes.textile FOLDERS README_INDEX.rdoc README.markdown"
+
+RUBY_FAKEGEM_GEMSPEC="coderay.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Ruby library for syntax highlighting"
+HOMEPAGE="http://coderay.rubychan.de/"
+SRC_URI="https://github.com/rubychan/coderay/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+PATCHES=("${FILESDIR}/${P}-ruby30.patch")
+
+# Redcloth is an optional but automagically tested dependency. This
+# requires redcloth-4.2.2. We don't depend on this version to make
+# bootstrapping rspec with new versions easier, since redcloth depends
+# on rake-compiler.
+
+ruby_add_bdepend "test? ( dev-ruby/rspec:3 )"
+
+all_ruby_prepare() {
+ sed -i -e "/[Bb]undler/d" Rakefile || die
+ sed -i -e '/git ls-files/ s:^:#:' -e 's/.rc.*"/"/' coderay.gemspec || die
+ sed -i -e '/simplecov/ s:^:#:' spec/spec_helper.rb test/*/*.rb || die
+
+ # Fix failing tests for lazy evaluation in ruby26
+ sed -i -e 's/\.filter$/.filter.to_a/' test/unit/filter.rb || die
+}