summaryrefslogtreecommitdiff
path: root/dev-ruby/coderay/coderay-1.1.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-21 11:40:40 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-21 11:40:40 +0000
commitbae478b64a6bc9eca66b65bcfa318fc21e7f34bb (patch)
treef713006fd9c119e5dbb3bdafe7d695d2644da94c /dev-ruby/coderay/coderay-1.1.3-r1.ebuild
parent374561aeaff53ce5a2836af934749923b4ea3763 (diff)
gentoo auto-resync : 21:01:2023 - 11:40:40
Diffstat (limited to 'dev-ruby/coderay/coderay-1.1.3-r1.ebuild')
-rw-r--r--dev-ruby/coderay/coderay-1.1.3-r1.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/dev-ruby/coderay/coderay-1.1.3-r1.ebuild b/dev-ruby/coderay/coderay-1.1.3-r1.ebuild
deleted file mode 100644
index 380b0699f14c..000000000000
--- a/dev-ruby/coderay/coderay-1.1.3-r1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-USE_RUBY="ruby25 ruby26 ruby27 ruby30"
-
-# The test target also contains test:exe but that requires
-# shoulda-context which we do not have packaged yet.
-RUBY_FAKEGEM_TASK_TEST="spec test:functional test:units"
-
-RUBY_FAKEGEM_TASK_DOC="doc"
-RUBY_FAKEGEM_DOCDIR="doc"
-
-RUBY_FAKEGEM_EXTRADOC="Changes-pre-1.0.textile Changes.textile FOLDERS README_INDEX.rdoc README.markdown"
-
-RUBY_FAKEGEM_GEMSPEC="coderay.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A Ruby library for syntax highlighting"
-HOMEPAGE="http://coderay.rubychan.de/"
-SRC_URI="https://github.com/rubychan/coderay/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-PATCHES=("${FILESDIR}/${P}-ruby30.patch")
-
-# Redcloth is an optional but automagically tested dependency. This
-# requires redcloth-4.2.2. We don't depend on this version to make
-# bootstrapping rspec with new versions easier, since redcloth depends
-# on rake-compiler.
-
-ruby_add_bdepend "test? ( dev-ruby/rspec:3 )"
-
-all_ruby_prepare() {
- sed -i -e "/[Bb]undler/d" Rakefile || die
- sed -i -e '/git ls-files/ s:^:#:' -e 's/.rc.*"/"/' coderay.gemspec || die
- sed -i -e '/simplecov/ s:^:#:' spec/spec_helper.rb test/*/*.rb || die
-
- # Fix failing tests for lazy evaluation in ruby26
- sed -i -e 's/\.filter$/.filter.to_a/' test/unit/filter.rb || die
-}