summaryrefslogtreecommitdiff
path: root/dev-ruby/classifier
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/classifier
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/classifier')
-rw-r--r--dev-ruby/classifier/Manifest3
-rw-r--r--dev-ruby/classifier/classifier-1.3.4.ebuild34
-rw-r--r--dev-ruby/classifier/metadata.xml11
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-ruby/classifier/Manifest b/dev-ruby/classifier/Manifest
new file mode 100644
index 000000000000..c6a8cd4ffc35
--- /dev/null
+++ b/dev-ruby/classifier/Manifest
@@ -0,0 +1,3 @@
+DIST classifier-1.3.4.gem 26112 BLAKE2B 61f7ac90dd4432f171abbf20ed822e5f553863e3bf487b4e97ab307df3e1c2212c129cc759a4d1647efa31fad00af7abb81fabf99c48da6df5c2e77778e40462 SHA512 b59fe17f7fe508d5f26584e14d5cd89eed8f77756b75a65adf2512116d0a67b716d14c2f742270fd14765567079a88264f5e1afe49d3865403814c4bdaf8f2f1
+EBUILD classifier-1.3.4.ebuild 990 BLAKE2B 28836fac04f1a0df9a03e8dde2b7cab6c0a95a1e2776a7ae70c833ce466342a02540d8a3bc21a9a202289662ab2619092a803a8ca990bdd9668338855dec90ea SHA512 acab34ab2bf50af1a9a65f683e4b9141d839609e45f29149fd34288430c1a1a12d83c689663dfa393feb64fcfd8807ecd54529b6867ace911fe67c6043f4e5e4
+MISC metadata.xml 346 BLAKE2B b0a975c5fa5219c578a2eb542744792cd5db4cc158e636ceafb0f4e04c460d8338499b3622f7cae014a1fc11259697adb3ac7a30d72449e28abeac1f55a5bf14 SHA512 01d4931bce6d5e0fe7fd5e6c84773420a3eeca9e98f9457872d1dd4ca24bddbdbc7bc96077d41858f155538e60c6bc2a997730612386caa6dea3c12434d77b10
diff --git a/dev-ruby/classifier/classifier-1.3.4.ebuild b/dev-ruby/classifier/classifier-1.3.4.ebuild
new file mode 100644
index 000000000000..3aecb200988c
--- /dev/null
+++ b/dev-ruby/classifier/classifier-1.3.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Module to allow Bayesian and other types of classifications"
+HOMEPAGE="http://rubyforge.org/projects/classifier https://github.com/cardmagic/classifier"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="gsl"
+
+ruby_add_rdepend ">=dev-ruby/fast-stemmer-1.0.0
+ !!dev-ruby/classifier-reborn
+ gsl? ( dev-ruby/rb-gsl )"
+
+all_ruby_prepare() {
+ sed -i -e "s/PKG_VERSION/\"${PV}\"/" \
+ -e '/rubyforge/ s:^:#:' \
+ -e "s#PKG_FILES#FileList[ \"lib/**/*\", \"bin/*\", \"test/**/*\", \"[A-Z]*\", \"Rakefile\", \"Gemfile\", \"html/**/*\"]#" Rakefile
+ if use !gsl; then
+ sed -e 's/$GSL = true/$GSL = false/' -i lib/${PN}/lsi.rb || die
+ rm test/lsi/lsi_test.rb || die
+ fi
+ # Remove failing test for now
+ rm test/extensions/word_hash_test.rb || die
+}
diff --git a/dev-ruby/classifier/metadata.xml b/dev-ruby/classifier/metadata.xml
new file mode 100644
index 000000000000..04461dc7b70a
--- /dev/null
+++ b/dev-ruby/classifier/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">cardmagic/classifier</remote-id>
+ </upstream>
+</pkgmetadata>