summaryrefslogtreecommitdiff
path: root/dev-ruby/classifier-reborn
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-14 13:40:00 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-14 13:40:00 +0100
commit3e627c1432765cb6a32877e73f985e8bfb5102ce (patch)
treee4d7919d9e1ca0a54c1a3758c86555d6e9121956 /dev-ruby/classifier-reborn
parent4a30f472147c2d8642bd558b78fcfce7b6a9c6b9 (diff)
gentoo auto-resync : 14:07:2022 - 13:40:00
Diffstat (limited to 'dev-ruby/classifier-reborn')
-rw-r--r--dev-ruby/classifier-reborn/Manifest2
-rw-r--r--dev-ruby/classifier-reborn/classifier-reborn-2.3.0.ebuild39
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-ruby/classifier-reborn/Manifest b/dev-ruby/classifier-reborn/Manifest
index 30426219e374..6bf7a44fcd85 100644
--- a/dev-ruby/classifier-reborn/Manifest
+++ b/dev-ruby/classifier-reborn/Manifest
@@ -1,3 +1,5 @@
DIST classifier-reborn-2.2.0.tar.gz 319010 BLAKE2B f4bd3259b9d6e324f3f0feb06dfd1c8736eaa8ae0f687e488b6e11b9cda8e6bf9e56a175c01dfb9352184da1a030d1330e22917c7bfdcb4242fa0102f6291940 SHA512 d299ce8f3b96de5c6194e816d880ebb895faaacdc2a19985166bdc3d9760242ec41d85f22167ea66e9afd743f5d91d63881da02882d1a412fc95a0c5db63d04c
+DIST classifier-reborn-2.3.0.tar.gz 325647 BLAKE2B eb663b0e12440e508bbd882e4f72c790445916e5e19234d4d50d5f20a692f0a7bbd45348e898a9782798ccc82568ccc825bc1477f02885cf33f9a9aab90ab10b SHA512 428073f63ce93cc6284275f92063fa092e3cbd99817a2d6650bafc46ac91fba240ce5ccb09f428b10818c24b04de56dd88090ab0d1cffd644b381a88d9c92050
EBUILD classifier-reborn-2.2.0.ebuild 1037 BLAKE2B c58d59a100eb9b5d94f92a7702a8fb66108818ed76b9ba3a0d867b2b6db03d999aa452d7d094d656910ade838cbed49f2001adc567ece206fb00256836deb297 SHA512 b0d3afcc4447980560faed70446360c40fb8c678d64e0eb11f9bcc102bd5130c3dc41b8e3a31cb21ac59e0cb9609fe5bdefd81e314e6e72e89281b90a2b2bb58
+EBUILD classifier-reborn-2.3.0.ebuild 1054 BLAKE2B 63a6febb5dbd3b81865883a00aa168139d4fdda09a62808850d2984f9694dfe68159eebddb0f3f1ef9b0d5a19dfd9e1fd6e949fd201d1beb3332e4d27d39d1e4 SHA512 daac8269c3987569a9450ca78003225c974518571b2382a0e26ce1282da835081d0ff9ccd8aad9e6469ca2f980b75220b9349980faf67ed722b82fdda85ec204
MISC metadata.xml 351 BLAKE2B 48faea9b6a17e4edc671f8dc753fdb1968422e34c7c4613b9f7a732cc16fa0440b90c2a70e64a2145045bf175cca4b14955de0fd0af55b85273e64ccbdbf5466 SHA512 5de25b87f655d8e8e029a753e8fb27692b32b8050250b92ce8513637321524db56d6061dc0f7b8c94af2e567ce5f073fda3b5977ad00d416107dcc5e2e95e8c0
diff --git a/dev-ruby/classifier-reborn/classifier-reborn-2.3.0.ebuild b/dev-ruby/classifier-reborn/classifier-reborn-2.3.0.ebuild
new file mode 100644
index 000000000000..7991fe3b1ef3
--- /dev/null
+++ b/dev-ruby/classifier-reborn/classifier-reborn-2.3.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+RUBY_FAKEGEM_GEMSPEC="classifier-reborn.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Module to allow Bayesian and other types of classifications"
+HOMEPAGE="https://github.com/jekyll/classifier-reborn"
+SRC_URI="https://github.com/jekyll/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="gsl test"
+
+ruby_add_rdepend "
+ >=dev-ruby/fast-stemmer-1.0.0
+ >=dev-ruby/matrix-0.4:0
+ gsl? ( dev-ruby/rb-gsl )"
+ruby_add_bdepend "test? ( dev-ruby/redis )"
+
+all_ruby_prepare() {
+ sed -i -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ sed -i -e "/[Bb]undler/d" Rakefile || die
+ if use !gsl; then
+ sed -e 's/$GSL = true/$GSL = false/'\
+ -e 's/vector_serialize/vector/'\
+ -i lib/${PN}/lsi.rb || die
+ fi
+
+ sed -i -e '/reporters/I s:^:#:' -e '/pry/ s:^:#:' test/test_helper.rb || die
+}