summaryrefslogtreecommitdiff
path: root/dev-ruby/childprocess/childprocess-3.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-ruby/childprocess/childprocess-3.0.0.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-ruby/childprocess/childprocess-3.0.0.ebuild')
-rw-r--r--dev-ruby/childprocess/childprocess-3.0.0.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/dev-ruby/childprocess/childprocess-3.0.0.ebuild b/dev-ruby/childprocess/childprocess-3.0.0.ebuild
deleted file mode 100644
index 8ab0dffa83b8..000000000000
--- a/dev-ruby/childprocess/childprocess-3.0.0.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-USE_RUBY="ruby24 ruby25 ruby26 ruby27"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_EXTRADOC="README.md"
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Solution for controlling external programs running in the background"
-HOMEPAGE="https://github.com/jarib/childprocess"
-
-LICENSE="MIT"
-SLOT="2"
-KEYWORDS="amd64 arm arm64 ~hppa ppc ppc64 ~s390 sparc x86"
-IUSE=""
-
-ruby_add_rdepend ">=dev-ruby/ffi-1.0.11"
-
-all_ruby_prepare() {
- # Remove bundler support
- rm Gemfile || die
- sed -i -e "/[Bb]undler/d" Rakefile || die
- sed -i -e "/[Cc]overalls/d" spec/spec_helper.rb || die
- sed -i -e 's/git ls-files/find/' ${RUBY_FAKEGEM_GEMSPEC} || die
-}
-
-each_ruby_prepare() {
- sed -i -e "s:'ruby':'"${RUBY}"':" spec/childprocess_spec.rb || die
-}
-
-each_ruby_test() {
- RUBYLIB=lib RSPEC_VERSION=3 ruby-ng_rspec
-}