summaryrefslogtreecommitdiff
path: root/dev-ruby/childlabor
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/childlabor
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/childlabor')
-rw-r--r--dev-ruby/childlabor/Manifest3
-rw-r--r--dev-ruby/childlabor/childlabor-0.0.3-r1.ebuild36
-rw-r--r--dev-ruby/childlabor/metadata.xml11
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-ruby/childlabor/Manifest b/dev-ruby/childlabor/Manifest
new file mode 100644
index 000000000000..731fb79841a7
--- /dev/null
+++ b/dev-ruby/childlabor/Manifest
@@ -0,0 +1,3 @@
+DIST childlabor-0.0.3.tar.gz 3120 BLAKE2B 555310e2b6b70292b580451b3627973a2cfc33ae0a8ceb5507fcc92ee70f388802644b1586c18736b34339418a9aaa6450f07e5353f3925a7238f02d397a640a SHA512 d18f3f90204b12e3b4a21be1439fcf44a4eb9f905402633966e6ab2a3cc9412a28c502a8c78487834a82e1de24f0f905691f33f443de930f670c70b17288fb6e
+EBUILD childlabor-0.0.3-r1.ebuild 992 BLAKE2B 84825f9aaae7e51ab03e25805436930c2c6749cea6a6bbfe1b0402b03f2731a8378aab0fd49b8198374ac0f6b307072320b7a7c055e3cf342587129017d622ef SHA512 419af899a14b12a8e6bb785a6d68e8ac1f742a9fff55dd0cf2331907c865693174fcb91f08b513783d0316ae5b56304e8c721dc009d9c3cbf41f42265778e40a
+MISC metadata.xml 347 BLAKE2B ea49d96c4573f6745df3c4c8860dea85853c85ccb5a808ef12a17ff29b056ec2926aec13637d11c9ab90d97937442ef57c5f4ea3ee6bed22dbf64102c4fe00f1 SHA512 6980c0bf12588c2926a0cd5bdbb7c976768764ef423587dcb9c061ddc577516f98d979092de978c9c7ee16acbc17eb30282560f505204f5a2da1e67a6f37e927
diff --git a/dev-ruby/childlabor/childlabor-0.0.3-r1.ebuild b/dev-ruby/childlabor/childlabor-0.0.3-r1.ebuild
new file mode 100644
index 000000000000..43443b66195a
--- /dev/null
+++ b/dev-ruby/childlabor/childlabor-0.0.3-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_DOCDIR=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A scripting framework that replaces rake and sake"
+HOMEPAGE="https://github.com/carllerche/childlabor"
+COMMIT_ID="6518b939dddbad20c7f05aa075d76e3ca6e70447"
+SRC_URI="https://github.com/carllerche/childlabor/archive/${COMMIT_ID}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE="test"
+
+RUBY_S="${PN}-${COMMIT_ID}"
+
+ruby_add_bdepend "test? ( dev-ruby/rspec:2 )"
+
+all_ruby_prepare() {
+ # Avoid failing spec. The signals work, but the stdout handling
+ # doesn't seem to play nice with portage.
+ sed -i -e '/can send signals/,/^ end/ s:^:#:' spec/task_spec.rb || die
+}
+
+each_ruby_test() {
+ ruby-ng_rspec -I. spec/task_spec.rb || die
+}
diff --git a/dev-ruby/childlabor/metadata.xml b/dev-ruby/childlabor/metadata.xml
new file mode 100644
index 000000000000..fb5ec591d30f
--- /dev/null
+++ b/dev-ruby/childlabor/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">carllerche/childlabor</remote-id>
+ </upstream>
+</pkgmetadata>