summaryrefslogtreecommitdiff
path: root/dev-ruby/childlabor/childlabor-0.0.3-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-14 08:25:25 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-14 08:25:25 +0100
commit53b3135150fc3b8f4831f8cc9d83276228e94916 (patch)
tree87312477d501929adecfd917e75ada3089c3641c /dev-ruby/childlabor/childlabor-0.0.3-r2.ebuild
parent77a57b2d524e4149890d25e1ea50f776d6551b19 (diff)
gentoo auto-resync : 14:08:2022 - 08:25:25
Diffstat (limited to 'dev-ruby/childlabor/childlabor-0.0.3-r2.ebuild')
-rw-r--r--dev-ruby/childlabor/childlabor-0.0.3-r2.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/dev-ruby/childlabor/childlabor-0.0.3-r2.ebuild b/dev-ruby/childlabor/childlabor-0.0.3-r2.ebuild
index 4763c3f12caf..fbb289f86b30 100644
--- a/dev-ruby/childlabor/childlabor-0.0.3-r2.ebuild
+++ b/dev-ruby/childlabor/childlabor-0.0.3-r2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-USE_RUBY="ruby26 ruby27"
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_TASK_TEST=""
@@ -24,14 +24,18 @@ IUSE="test"
RUBY_S="${PN}-${COMMIT_ID}"
-ruby_add_bdepend "test? ( dev-ruby/rspec:2 )"
+ruby_add_bdepend "test? ( dev-ruby/rspec:3 )"
all_ruby_prepare() {
# Avoid failing spec. The signals work, but the stdout handling
# doesn't seem to play nice with portage.
sed -i -e '/can send signals/,/^ end/ s:^:#:' spec/task_spec.rb || die
+
+ # Rspec 3 compatibility
+ sed -i -e 's/Spec::Runner/RSpec/' spec/spec_helper.rb || die
+ sed -i -e 's/be_false/be_falsey/ ; s/be_true/be true/' spec/task_spec.rb || die
}
each_ruby_test() {
- ruby-ng_rspec -I. spec/task_spec.rb || die
+ RSPEC_VERSION=3 ruby-ng_rspec -I. spec/task_spec.rb || die
}