summaryrefslogtreecommitdiff
path: root/dev-ruby/certificate_authority
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
commit9452a6e87b6c2c70513bc47a2470bf9f1168920e (patch)
tree8ac67e26b45f34d71c5aab3621813b100a0d5f00 /dev-ruby/certificate_authority
parentf516638b7fe9592837389826a6152a7e1b251c54 (diff)
gentoo resync : 13.06.2020
Diffstat (limited to 'dev-ruby/certificate_authority')
-rw-r--r--dev-ruby/certificate_authority/Manifest2
-rw-r--r--dev-ruby/certificate_authority/certificate_authority-1.0.0.ebuild32
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/certificate_authority/Manifest b/dev-ruby/certificate_authority/Manifest
index df76838d098c..0067e53294cf 100644
--- a/dev-ruby/certificate_authority/Manifest
+++ b/dev-ruby/certificate_authority/Manifest
@@ -1,3 +1,5 @@
DIST certificate_authority-0.1.6.gem 22528 BLAKE2B 85b229c7506b787b85b734883967dd8e6fc4ceece57dec2b2b8c29fffbaec2d95931af5412d61ef9935e547b68b14213e5cc6971f94ad6294476cc653684742b SHA512 d1471171aa01956ca216bdb8515e9f6fafc9720827e7351b14c7c38907e87b66a3299d9ee0322fb51b8edd1cbc4f4a73a2aa4b54ff5ca4c8bc602ced5e035a59
+DIST certificate_authority-1.0.0.tar.gz 57104 BLAKE2B e585b19b6740349e520e021d4981c3941bca9e6c9b11867c9484e98b4e74e4ebafb47c648564c3e8b89e3591414a90ee404bab83cafd5a3354354b36b3002436 SHA512 e5f05d3df86ae7e7e6ed8937667b14229cda884996c30d9a39f1ad7db781e58abb3f61c251c21174b4988adf0ecdecb1b0f22ed97ddae071ba12c78379524785
EBUILD certificate_authority-0.1.6-r2.ebuild 769 BLAKE2B c58170c67cea3905725ae6add40477d403281c33f12c33088d5d880fe83f13797746c71edda58547bc0b0bba59fa76fdc91b0da42fb0ebf9acb21b2d6af23607 SHA512 2ce877bf95e8d45bb5770939c3a940e361e1c075e1e2bf2a1907f2c3eeed96fac4e3e51df5eb0996c7d4d404302af94c2788201363ab4768b08a42a679f33eba
+EBUILD certificate_authority-1.0.0.ebuild 981 BLAKE2B 940b0e2f8bd52db73e417d5021cc1f04e3555556824e3c66b7c15a2f6f34a475f8c971f5d23b2f412e9cba9c6614198a44dd5ace3b729032ec25d572793bbe7c SHA512 e463708720d9b59fbc96d9833acb4c668d6d608dc8425bdeff3b86ce5eb7b7a18e0ab4c8d3dc70003dbae6f7b745050a6663e3c531cdab22d0d8744ae66eb878
MISC metadata.xml 357 BLAKE2B 5e69b9b9001e7dcc322333c2cc3f451afded531e07b9942eac2dc59a6c61ceba864f2799487345cee4b5b0540b5952c7c312dfaa9e20f9b1373c4bbeac57c33c SHA512 e0e2a1493426c800a142ccf475ab1d0ab60511b30c28fd6bc927d9672281f6377eaa607596acb6b9b1fd2b949231b4a1b01ce8137725f5f4632ffaf7b62eb932
diff --git a/dev-ruby/certificate_authority/certificate_authority-1.0.0.ebuild b/dev-ruby/certificate_authority/certificate_authority-1.0.0.ebuild
new file mode 100644
index 000000000000..a49df5a8922d
--- /dev/null
+++ b/dev-ruby/certificate_authority/certificate_authority-1.0.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="certificate_authority.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Managing the core functions outlined in RFC-3280 for PKI"
+HOMEPAGE="https://github.com/cchandler/certificate_authority"
+SRC_URI="https://github.com/cchandler/certificate_authority/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/\(bundler\|pry\|overalls\)/ s:^:#:' spec/spec_helper.rb || die
+ sed -i -e '/spec.files/,/end/ s:^:#:' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Avoid dependency on dev-libs/engine_pkcs11 that will be hard to
+ # make work on different arches due to hardwired load paths in
+ # specs.
+ rm -f spec/units/pkcs11_key_material_spec.rb || die
+}