summaryrefslogtreecommitdiff
path: root/dev-ruby/certificate_authority
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ruby/certificate_authority
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ruby/certificate_authority')
-rw-r--r--dev-ruby/certificate_authority/Manifest6
-rw-r--r--dev-ruby/certificate_authority/certificate_authority-0.1.6-r1.ebuild29
-rw-r--r--dev-ruby/certificate_authority/certificate_authority-0.1.6-r2.ebuild29
-rw-r--r--dev-ruby/certificate_authority/metadata.xml11
4 files changed, 75 insertions, 0 deletions
diff --git a/dev-ruby/certificate_authority/Manifest b/dev-ruby/certificate_authority/Manifest
new file mode 100644
index 000000000000..96ef11d46de0
--- /dev/null
+++ b/dev-ruby/certificate_authority/Manifest
@@ -0,0 +1,6 @@
+DIST certificate_authority-0.1.6.gem 22528 SHA256 4b1f7d2df1685650ceeb23aa01b20d89221d3435388c7db8b205fb199bb4d5f8 SHA512 d1471171aa01956ca216bdb8515e9f6fafc9720827e7351b14c7c38907e87b66a3299d9ee0322fb51b8edd1cbc4f4a73a2aa4b54ff5ca4c8bc602ced5e035a59 WHIRLPOOL 291a2ff004b335c9776c8b2d497592c1b0b2598eb2b56df7428d6679540341e1ac821246db14bd8227632b929e7a507ca73ebe4f943c50b06b8b3b7171634ad1
+EBUILD certificate_authority-0.1.6-r1.ebuild 753 SHA256 b88c763b182858ee4d6ac0d745d4c0eb3c23afe91f66f4c83ea03f188d4e6698 SHA512 1cc1e964a685a00f06762ec38d1cab9e68eb633b9bd19a9b20baa647fbff31ace34204681f427b795e4c0f16f5366ae84f696ab5724b216b9fe78db1bc7c2279 WHIRLPOOL b6fc3f41f5dad33a26f6b8e02296a11820163ea8220b30adc7d46a39fcf0f21963ab415b55327af128abc3b4ab2affe5041f894af2ba3095f61949bf514d2a5e
+EBUILD certificate_authority-0.1.6-r2.ebuild 750 SHA256 656807adfc22acc46714eb5c92289be004422141a183bad5fdf7a403616cdbf8 SHA512 233df6f70b090b5449a08f509c95bc27f957fc3a1853a18376cb17f082922364571f6326e07b7eab76ce2b4a8a635ed6ce642fbd62703a226d0ff8c088cd822f WHIRLPOOL d7985b9d9cf850316aa0c4332bb3796dc3adcd9dce43fc7a43b9e67514c59551811929bab4d7c035cf740963ddc1dd934247615d41927cd9c714ffcc6aafc79f
+MISC ChangeLog 2943 SHA256 46c289b766d474184ff1a924219ad7f54252b740b4ef523dfaaf0a0d49305678 SHA512 30fc8d18857f2666a774ad488646f93c59352d9185f2ea3120382edfb5d2c0fca4345ea243b4760feb07083f4d48b22d60ec5b137d7ff7ede3a2b9b0a553e910 WHIRLPOOL 7597bd6b453b69c008a4ad5d46a2e5ba081fcf6bd54e8418154b9ff0e89541780fa67a3c7c037180d78e1b07086b346f27eed9d12c799e3c45cf1cb43b5a96fc
+MISC ChangeLog-2015 782 SHA256 defd58e89f34f399038a220fadfc1d87eef70eddb1f160fc88e9918fe16b56dc SHA512 8f40dae3aac66576da7d84b515d30a02225a03ad2881a5efa2d17a5b3ad30bbcfced1d076cddabac3e48a8e12f7c00578f2df5861acdace151a6a60c6e4adcde WHIRLPOOL 7c6fedbe2253cb40070459ccb987ee00f9ef11fd8402ca7730f9c67035b3922ad41a7dd1ce0ae83313590458d3be528f53312bfc4573829bbd4e8a89d1a285fd
+MISC metadata.xml 357 SHA256 97f57f84c7994f58463677cedfd830630e254c527098d313e48224ebd6e367a8 SHA512 e0e2a1493426c800a142ccf475ab1d0ab60511b30c28fd6bc927d9672281f6377eaa607596acb6b9b1fd2b949231b4a1b01ce8137725f5f4632ffaf7b62eb932 WHIRLPOOL 05902eeeb2e22215ea913825b2f2c1b872ee7651ff2020f2844520a8ef3d6068fc8425ae13ddf14e32ca932f82bf9751748df17f16892fecc4dd5ec58d97fbf8
diff --git a/dev-ruby/certificate_authority/certificate_authority-0.1.6-r1.ebuild b/dev-ruby/certificate_authority/certificate_authority-0.1.6-r1.ebuild
new file mode 100644
index 000000000000..b96935ebd5ff
--- /dev/null
+++ b/dev-ruby/certificate_authority/certificate_authority-0.1.6-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Managing the core functions outlined in RFC-3280 for PKI"
+HOMEPAGE="https://github.com/cchandler/certificate_authority"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/activemodel-3.0.6:*"
+
+all_ruby_prepare() {
+ # Avoid dependency on dev-libs/engine_pkcs11 that will be hard to
+ # make work on different arches due to hardwired load paths in
+ # specs.
+ rm -f spec/units/pkcs11_key_material_spec.rb || die
+}
diff --git a/dev-ruby/certificate_authority/certificate_authority-0.1.6-r2.ebuild b/dev-ruby/certificate_authority/certificate_authority-0.1.6-r2.ebuild
new file mode 100644
index 000000000000..037269cd4b8c
--- /dev/null
+++ b/dev-ruby/certificate_authority/certificate_authority-0.1.6-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Managing the core functions outlined in RFC-3280 for PKI"
+HOMEPAGE="https://github.com/cchandler/certificate_authority"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/activemodel-3.0.6:*"
+
+all_ruby_prepare() {
+ # Avoid dependency on dev-libs/engine_pkcs11 that will be hard to
+ # make work on different arches due to hardwired load paths in
+ # specs.
+ rm -f spec/units/pkcs11_key_material_spec.rb || die
+}
diff --git a/dev-ruby/certificate_authority/metadata.xml b/dev-ruby/certificate_authority/metadata.xml
new file mode 100644
index 000000000000..6efe7307345f
--- /dev/null
+++ b/dev-ruby/certificate_authority/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">cchandler/certificate_authority</remote-id>
+ </upstream>
+</pkgmetadata>