summaryrefslogtreecommitdiff
path: root/dev-ruby/certificate_authority
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /dev-ruby/certificate_authority
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'dev-ruby/certificate_authority')
-rw-r--r--dev-ruby/certificate_authority/Manifest2
-rw-r--r--dev-ruby/certificate_authority/certificate_authority-1.1.0.ebuild32
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/certificate_authority/Manifest b/dev-ruby/certificate_authority/Manifest
index 7388baf9e916..3ee654cc12c4 100644
--- a/dev-ruby/certificate_authority/Manifest
+++ b/dev-ruby/certificate_authority/Manifest
@@ -1,3 +1,5 @@
DIST certificate_authority-1.0.0.tar.gz 57104 BLAKE2B e585b19b6740349e520e021d4981c3941bca9e6c9b11867c9484e98b4e74e4ebafb47c648564c3e8b89e3591414a90ee404bab83cafd5a3354354b36b3002436 SHA512 e5f05d3df86ae7e7e6ed8937667b14229cda884996c30d9a39f1ad7db781e58abb3f61c251c21174b4988adf0ecdecb1b0f22ed97ddae071ba12c78379524785
+DIST certificate_authority-1.1.0.tar.gz 57457 BLAKE2B 6714359fd869cce2a0b43aa6321e95229dead04ed761f6239ecb7b988548aabf13c62a3c61e20d539a6003395886e5e4ff2366fabaa395bfd4b4761c55d56555 SHA512 52c79acaaacf471206912165d2b07464158b61acd8b65ad73614900baa208694f9d29107cc0e275d09baa580ecfbc95458ac7772370b423762d4e80ddf0237ca
EBUILD certificate_authority-1.0.0.ebuild 987 BLAKE2B 7edc468007f93baf79c286438cd139c287e7819677860d2c3caf1272a25e39f6aef7eef76970cad95a6bd31ceab255a2b936e2cc3aa7fdd607f1140cae022bc0 SHA512 803f9a868d3c9eaf42ca80a13201669574b69cac707be83b741fae98c63f9a642e48245602cac64b42f51d0bebdda417c8de47871b1aa9a4af01d1b9437e70bc
+EBUILD certificate_authority-1.1.0.ebuild 988 BLAKE2B 55f19e34c31464e7f0883a931a98d5e93990782c2622714febe56e6eb506e90ec44aefded7dbf92b90feaa2853daac0dd5c7564ace944d791ff2632b93371a5e SHA512 2274f2f3f1a9ea807ffa1587bd636a1feca79b6717ddbc1dbb1af3833c0fb53271046b4a5a7c2bc912f845f00456aed940281ea15b7a02f2c8c777624baeb363
MISC metadata.xml 358 BLAKE2B 9481f4365e35e21c255c572608085070dacffd97b9a66ca3a530096792cac609d9e357bd69e44a094d16edfe1c772835cef2f9d28d0dc9430b28c3eec6870d54 SHA512 00880faf802e45165b1d4e4eac5ecfe197a02bbc15a797eff0f008bf5a88389283702814a1a65677152a529c3b6353d0845f45b3fa0a72ef6cfc08bf12331dc2
diff --git a/dev-ruby/certificate_authority/certificate_authority-1.1.0.ebuild b/dev-ruby/certificate_authority/certificate_authority-1.1.0.ebuild
new file mode 100644
index 000000000000..64770fbd1db8
--- /dev/null
+++ b/dev-ruby/certificate_authority/certificate_authority-1.1.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="certificate_authority.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Managing the core functions outlined in RFC-3280 for PKI"
+HOMEPAGE="https://github.com/cchandler/certificate_authority"
+SRC_URI="https://github.com/cchandler/certificate_authority/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/\(bundler\|pry\|overalls\)/ s:^:#:' spec/spec_helper.rb || die
+ sed -i -e '/spec.files/,/end/ s:^:#:' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Avoid dependency on dev-libs/engine_pkcs11 that will be hard to
+ # make work on different arches due to hardwired load paths in
+ # specs.
+ rm -f spec/units/pkcs11_key_material_spec.rb || die
+}