summaryrefslogtreecommitdiff
path: root/dev-ruby/celluloid-extras
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/celluloid-extras
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/celluloid-extras')
-rw-r--r--dev-ruby/celluloid-extras/Manifest3
-rw-r--r--dev-ruby/celluloid-extras/celluloid-extras-0.20.5.ebuild33
-rw-r--r--dev-ruby/celluloid-extras/metadata.xml11
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-ruby/celluloid-extras/Manifest b/dev-ruby/celluloid-extras/Manifest
new file mode 100644
index 000000000000..0d9ee19a220b
--- /dev/null
+++ b/dev-ruby/celluloid-extras/Manifest
@@ -0,0 +1,3 @@
+DIST celluloid-extras-0.20.5.tar.gz 3632 BLAKE2B 916e4f76f0b4ef67699d861e0b8096d56c5feb8d96ddad4dfe4c3f96d9291ce50ee037b0f7cd7bfa78b420252288dc068eb184f905a89eeeaeac6ba7d8d589e9 SHA512 99f78a8f5761d205acc5ec1a2e88889eca59b7c4c979e959f691c60e7700dd06ad72afa88d785451bbf0ec554f6fdb2e7f2fae5870020ad0a6676522832f6767
+EBUILD celluloid-extras-0.20.5.ebuild 891 BLAKE2B f38ebd4fd37434a25bf3c6562a69c076b43eb8de398233c662d42d55a01a1ef7458a2430fca7d38775d1e7d8ee9aa2022537a961dce5f3df4ea6e4e660826546 SHA512 2cd091557e60c1a73b00172e4c83810d92e13b98497f67b1eeaa77ebb697cd8ad2d8a5af34ba7b56d1c664e3deebcae02c74209c96adf32ac0af4b1ed470379f
+MISC metadata.xml 352 BLAKE2B 44318014198af49113c84f1afbf81f8b8dd43a2d2a8609f229c12d11cc40675c2d501ad3deec2bb189b25629970add495517a922ffc5f1b57c87749538e66588 SHA512 e8aa4c3d5a3f09c91d0979def4ae83952e54bbc086df3032bf2e3b48748e5e26962d88c8f39d397e09e4c21e996af671daa8fa62352ab354c9d488da4099cc39
diff --git a/dev-ruby/celluloid-extras/celluloid-extras-0.20.5.ebuild b/dev-ruby/celluloid-extras/celluloid-extras-0.20.5.ebuild
new file mode 100644
index 000000000000..5894a475626e
--- /dev/null
+++ b/dev-ruby/celluloid-extras/celluloid-extras-0.20.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Provides a simple and natural way to build fault-tolerant concurrent programs"
+HOMEPAGE="https://github.com/celluloid/celluloid"
+SRC_URI="https://github.com/celluloid/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+IUSE=""
+SLOT="0"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+ruby_add_rdepend "
+ >=dev-ruby/timers-4.1.1"
+
+ruby_add_bdepend "test? (
+ dev-ruby/celluloid
+ dev-ruby/nenv
+ dev-ruby/rspec-retry
+)"
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/d' -e '/coveralls/I s:^:#:' spec/spec_helper.rb || die
+}
diff --git a/dev-ruby/celluloid-extras/metadata.xml b/dev-ruby/celluloid-extras/metadata.xml
new file mode 100644
index 000000000000..69905405c8a3
--- /dev/null
+++ b/dev-ruby/celluloid-extras/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">celluloid/celluloid-extras</remote-id>
+ </upstream>
+</pkgmetadata>