summaryrefslogtreecommitdiff
path: root/dev-ruby/capistrano/capistrano-3.17.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-08 08:13:35 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-08 08:13:35 +0100
commitc69ad4e8f72085fe4d18df4b5abccb7b0ed73288 (patch)
treec8682880ff2e2fc8b75533cf224d7884950e5371 /dev-ruby/capistrano/capistrano-3.17.1.ebuild
parentc30a3f925914edfc7c93158227b5eed3663e6efa (diff)
gentoo auto-resync : 08:08:2022 - 08:13:35
Diffstat (limited to 'dev-ruby/capistrano/capistrano-3.17.1.ebuild')
-rw-r--r--dev-ruby/capistrano/capistrano-3.17.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-ruby/capistrano/capistrano-3.17.1.ebuild b/dev-ruby/capistrano/capistrano-3.17.1.ebuild
new file mode 100644
index 000000000000..d7806d8a3b3e
--- /dev/null
+++ b/dev-ruby/capistrano/capistrano-3.17.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A distributed application deployment system"
+HOMEPAGE="https://capistranorb.com/"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/airbrussh-1.0.0
+ >=dev-ruby/sshkit-1.9:0
+ >=dev-ruby/rake-10.0.0
+ dev-ruby/i18n:*"
+ruby_add_bdepend "
+ test? ( dev-ruby/mocha )"
+
+all_ruby_prepare() {
+ # Avoid specs that depend on capistrano already being installed
+ rm -f spec/lib/capistrano/doctor/gems_doctor_spec.rb || die
+
+ # Avoid specs that require a TTY
+ sed -i -e '/asking for a variable/,/^ end/ s:^:#:' spec/integration/dsl_spec.rb || die
+ rm -f spec/lib/capistrano/configuration/question_spec.rb spec/lib/capistrano/doctor/output_helpers_spec.rb || die
+}