summaryrefslogtreecommitdiff
path: root/dev-ruby/bundler/bundler-2.4.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-08 12:15:59 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-08 12:15:59 +0000
commit6a57f9ee53dc794f3d47ea68f78d6ef76d00af47 (patch)
treedc9e574f3209abd88e91e2ee0d6093f4fe78e2d3 /dev-ruby/bundler/bundler-2.4.3.ebuild
parent268f9f01921ccb921b794d43092c5f29c1e96c56 (diff)
gentoo auto-resync : 08:01:2023 - 12:15:59
Diffstat (limited to 'dev-ruby/bundler/bundler-2.4.3.ebuild')
-rw-r--r--dev-ruby/bundler/bundler-2.4.3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/bundler/bundler-2.4.3.ebuild b/dev-ruby/bundler/bundler-2.4.3.ebuild
new file mode 100644
index 000000000000..1ac24d655f96
--- /dev/null
+++ b/dev-ruby/bundler/bundler-2.4.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31"
+
+# The specs require a number of gems to be installed in a temporary
+# directory, but this requires network access. They also don't work
+# when run with a path that contains "-".
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+# No documentation task
+RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md"
+
+RUBY_FAKEGEM_BINDIR="exe"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An easy way to vendor gem dependencies"
+HOMEPAGE="https://github.com/carlhuda/bundler"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+
+ruby_add_rdepend virtual/rubygems
+
+RDEPEND+=" dev-vcs/git"