summaryrefslogtreecommitdiff
path: root/dev-ruby/bundler-audit/bundler-audit-0.9.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /dev-ruby/bundler-audit/bundler-audit-0.9.0.1.ebuild
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'dev-ruby/bundler-audit/bundler-audit-0.9.0.1.ebuild')
-rw-r--r--dev-ruby/bundler-audit/bundler-audit-0.9.0.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-ruby/bundler-audit/bundler-audit-0.9.0.1.ebuild b/dev-ruby/bundler-audit/bundler-audit-0.9.0.1.ebuild
new file mode 100644
index 000000000000..34c66400cad6
--- /dev/null
+++ b/dev-ruby/bundler-audit/bundler-audit-0.9.0.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Provides patch-level verification for Bundled apps"
+HOMEPAGE="https://github.com/rubysec/bundler-audit"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+#tests are trying to download AND have some odd failures
+#rspec ./spec/database_spec.rb:113 # Bundler::Audit::Database#size should eq 323
+#rspec ./spec/database_spec.rb:117 # Bundler::Audit::Database#advisories should return a list of all advisories.
+RESTRICT=test
+
+ruby_add_rdepend "
+ dev-ruby/thor:1
+ dev-ruby/bundler:2
+"
+
+all_ruby_prepare() {
+ sed -i -e '/simplecov/I s:^:#:' spec/spec_helper.rb || die
+
+ # Avoid specs that require network access via 'bundle install'
+ rm spec/{integration,scanner}_spec.rb || die
+
+ # Avoid specs that only work when the source is a git repository
+ sed -i -e '/describe "path"/,/^ end/ s:^:#:' \
+ -e '/describe "update!"/,/^ end/ s:^:#:' \
+ spec/database_spec.rb || die
+}