summaryrefslogtreecommitdiff
path: root/dev-ruby/bourne/bourne-1.6.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/bourne/bourne-1.6.0.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/bourne/bourne-1.6.0.ebuild')
-rw-r--r--dev-ruby/bourne/bourne-1.6.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/bourne/bourne-1.6.0.ebuild b/dev-ruby/bourne/bourne-1.6.0.ebuild
new file mode 100644
index 000000000000..2e540174232c
--- /dev/null
+++ b/dev-ruby/bourne/bourne-1.6.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_TASK_TEST="MOCHA_OPTIONS=use_test_unit_gem test:units test:acceptance"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Extends mocha to allow tracking and querying of stub and mock invocations"
+HOMEPAGE="https://github.com/thoughtbot/bourne"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/mocha-1.1:1.0"
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit:2 )"
+
+all_ruby_prepare() {
+ sed -i -e '/git ls-files/d' "${RUBY_FAKEGEM_GEMSPEC}" || die
+ sed -i -e '/bundler/d' Rakefile || die
+}