summaryrefslogtreecommitdiff
path: root/dev-ruby/bluecloth/bluecloth-2.2.0-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/bluecloth/bluecloth-2.2.0-r3.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/bluecloth/bluecloth-2.2.0-r3.ebuild')
-rw-r--r--dev-ruby/bluecloth/bluecloth-2.2.0-r3.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/dev-ruby/bluecloth/bluecloth-2.2.0-r3.ebuild b/dev-ruby/bluecloth/bluecloth-2.2.0-r3.ebuild
new file mode 100644
index 000000000000..210f75c76e43
--- /dev/null
+++ b/dev-ruby/bluecloth/bluecloth-2.2.0-r3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="History.rdoc README.rdoc"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+inherit multilib ruby-fakegem eutils
+
+DESCRIPTION="A Ruby implementation of Markdown"
+HOMEPAGE="http://www.deveiate.org/projects/BlueCloth"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 ~hppa ia64 ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="test"
+
+DEPEND+=" doc? ( dev-lang/perl )"
+
+ruby_add_bdepend "
+ dev-ruby/hoe
+ test? (
+ dev-ruby/diff-lcs
+ dev-ruby/tidy-ext
+ )"
+
+all_ruby_prepare() {
+ # for Ruby 1.9.2 and 2.2.x compatibility
+ sed -i -e '1i $: << "."' \
+ -e 's/Config/RbConfig/' Rakefile || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext extconf.rb || die
+}
+
+all_ruby_compile() {
+ pod2man --center --release --name bluecloth --utf8 bluecloth.1.pod bluecloth.1 || die
+
+ all_fakegem_compile
+}
+
+each_ruby_compile() {
+ emake -Cext
+ cp ext/bluecloth_ext$(get_modname) lib/ || die
+}
+
+all_ruby_install() {
+ doman man/man1/bluecloth.1
+
+ all_fakegem_install
+}