summaryrefslogtreecommitdiff
path: root/dev-ruby/blankslate/blankslate-3.1.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
commit5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (patch)
tree66e860a5099bcad013f1cf667255dc372a7c11b3 /dev-ruby/blankslate/blankslate-3.1.3-r1.ebuild
parent7218e1b46bceac05841e90472501742d905fb3fc (diff)
gentoo resync : 20.03.2021
Diffstat (limited to 'dev-ruby/blankslate/blankslate-3.1.3-r1.ebuild')
-rw-r--r--dev-ruby/blankslate/blankslate-3.1.3-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ruby/blankslate/blankslate-3.1.3-r1.ebuild b/dev-ruby/blankslate/blankslate-3.1.3-r1.ebuild
new file mode 100644
index 000000000000..5702189fe39c
--- /dev/null
+++ b/dev-ruby/blankslate/blankslate-3.1.3-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby25 ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTRADOC="README"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Base class with almost all of the methods from Object and Kernel being removed"
+HOMEPAGE="https://rubygems.org/gems/blankslate"
+
+IUSE=""
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+all_ruby_prepare() {
+ # Avoid test failing with rspec 2.x.
+ sed -i -e '/cleanliness/,/^ end/ s:^:#:' spec/blankslate_spec.rb || die
+}