summaryrefslogtreecommitdiff
path: root/dev-ruby/binding_of_caller
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/binding_of_caller
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/binding_of_caller')
-rw-r--r--dev-ruby/binding_of_caller/Manifest5
-rw-r--r--dev-ruby/binding_of_caller/binding_of_caller-0.7.3.ebuild26
-rw-r--r--dev-ruby/binding_of_caller/binding_of_caller-0.8.0.ebuild26
-rw-r--r--dev-ruby/binding_of_caller/metadata.xml11
4 files changed, 68 insertions, 0 deletions
diff --git a/dev-ruby/binding_of_caller/Manifest b/dev-ruby/binding_of_caller/Manifest
new file mode 100644
index 000000000000..a44ceb447c2e
--- /dev/null
+++ b/dev-ruby/binding_of_caller/Manifest
@@ -0,0 +1,5 @@
+DIST binding_of_caller-0.7.3.gem 87552 BLAKE2B 5cceef6f8be2d8360d55ffd6b82148411bd65aa56f811719840465e4e5fb77f88ebb1917eac1a5b65e24abf9ed0ad860afc2aff1e8309e4b6832bc3a0ee915df SHA512 e16bfc1fffe7e7d87013506a28f2894c3737a9dfd149ab4c7deee7332e6a3b8eecde5d837a58defcb0ad45a6a8d01ffd7b1e32a9395fa895d2dc84d8e534e547
+DIST binding_of_caller-0.8.0.gem 87552 BLAKE2B 9097fe2dbf1e5ea2361bee94cb83ce8152f7e1357caecf1217b1643be225e21e5aa793e7fccbef5c983d5c204b95e633ded490158dfdd1d4e99fca81c51cb910 SHA512 d6ea4e893415eaf3614b109f8f36c3fa2378da9997d013fccbd0fc1e598886d11f7843023ceed2468184d5b8df01e2329ef16c7af57bc60bbd47304a53b43974
+EBUILD binding_of_caller-0.7.3.ebuild 579 BLAKE2B 894a5bae0de92fb26304ddd094f6c72546024d91a0e1b5b2281e1cc2df825658f1a7369afdba943d7514fbd0f7862e46d98d891950f8dcfa50cd634466c88bbf SHA512 93d772c8e0403adfa39f2f1ccb7558568a0e930dba42a37986a4e9b9af12572f6f3d6dad08082bc831d60ceec835a44abb10725f32e29c83ae530b258064262b
+EBUILD binding_of_caller-0.8.0.ebuild 586 BLAKE2B e3507095a6001c604a64ab828b0b7601b17a4f5b6541d5cdbeb7aae37879dda50a37eaae54b5f4b6fa8e4cc4e8ead0ae40b004279663fba96ded64abe55ab573 SHA512 918315cff07ff29f9c974a4a41d1887b29bee0dde9d089ef8f108a2dc1553ad09ac9b945a0867f124fc35945b3eee17f199942d9683aa0b7aa647253fa8e830c
+MISC metadata.xml 352 BLAKE2B 1ff945eb6a72367cd1901603d59de20bc43ac45a07bcb525d7cb8641dc9cbab8493a19919a3600356d49082bc5563471926fe632cd0ccf5c0ba34d2445e31cdb SHA512 3774a75d46642d38c562d1a2cfe3c432cf3857801fb44b3da21ba2bbe9bd046b60d1bf4b5712efe66b9d875d407717a53f0a00a3516b631d05335f045f87fa23
diff --git a/dev-ruby/binding_of_caller/binding_of_caller-0.7.3.ebuild b/dev-ruby/binding_of_caller/binding_of_caller-0.7.3.ebuild
new file mode 100644
index 000000000000..db88afa35d4e
--- /dev/null
+++ b/dev-ruby/binding_of_caller/binding_of_caller-0.7.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="HISTORY README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Retrieve the binding of a method's caller"
+HOMEPAGE="https://github.com/banister/binding_of_caller"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+ruby_add_rdepend ">=dev-ruby/debug_inspector-0.0.1"
+
+ruby_add_bdepend "test? ( dev-ruby/bacon )"
+
+each_ruby_test() {
+ ${RUBY} -S bacon -Itest -rubygems -a -q || die
+}
diff --git a/dev-ruby/binding_of_caller/binding_of_caller-0.8.0.ebuild b/dev-ruby/binding_of_caller/binding_of_caller-0.8.0.ebuild
new file mode 100644
index 000000000000..3cb0f7f5dbed
--- /dev/null
+++ b/dev-ruby/binding_of_caller/binding_of_caller-0.8.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="HISTORY README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Retrieve the binding of a method's caller"
+HOMEPAGE="https://github.com/banister/binding_of_caller"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+ruby_add_rdepend ">=dev-ruby/debug_inspector-0.0.1"
+
+ruby_add_bdepend "test? ( dev-ruby/bacon )"
+
+each_ruby_test() {
+ ${RUBY} -S bacon -Itest -rubygems -a -q || die
+}
diff --git a/dev-ruby/binding_of_caller/metadata.xml b/dev-ruby/binding_of_caller/metadata.xml
new file mode 100644
index 000000000000..b7fe626b3cd7
--- /dev/null
+++ b/dev-ruby/binding_of_caller/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">banister/binding_of_caller</remote-id>
+ </upstream>
+</pkgmetadata>