summaryrefslogtreecommitdiff
path: root/dev-ruby/bindata/bindata-2.4.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /dev-ruby/bindata/bindata-2.4.7.ebuild
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'dev-ruby/bindata/bindata-2.4.7.ebuild')
-rw-r--r--dev-ruby/bindata/bindata-2.4.7.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ruby/bindata/bindata-2.4.7.ebuild b/dev-ruby/bindata/bindata-2.4.7.ebuild
new file mode 100644
index 000000000000..37680de8635e
--- /dev/null
+++ b/dev-ruby/bindata/bindata-2.4.7.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Parsing Binary Data in Ruby"
+HOMEPAGE="https://github.com/dmendel/bindata"
+
+LICENSE="BSD-2"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/minitest:5 )"
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+ sed -i -e '/[Cc]overalls/d' test/test_helper.rb || die
+}