summaryrefslogtreecommitdiff
path: root/dev-ruby/bigdecimal
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-02 10:15:56 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-02 10:15:56 +0100
commit15bd3dfb22c7ba23dad0823e326dbcb8bb31b892 (patch)
tree6da8c6fe191bb632a2a6454968d2d1cc1338a5dc /dev-ruby/bigdecimal
parentec82846d15c127f36a0f0620e30c9c0fbbdd514c (diff)
gentoo auto-resync : 02:09:2023 - 10:15:56
Diffstat (limited to 'dev-ruby/bigdecimal')
-rw-r--r--dev-ruby/bigdecimal/Manifest3
-rw-r--r--dev-ruby/bigdecimal/bigdecimal-3.1.4.ebuild31
-rw-r--r--dev-ruby/bigdecimal/metadata.xml11
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-ruby/bigdecimal/Manifest b/dev-ruby/bigdecimal/Manifest
new file mode 100644
index 000000000000..bbe5b675a414
--- /dev/null
+++ b/dev-ruby/bigdecimal/Manifest
@@ -0,0 +1,3 @@
+DIST bigdecimal-3.1.4.tar.gz 115069 BLAKE2B 7c7df4ceac6caa44414cf2fe4e16ee21b8d4a868097e5a6d3e7bdae8521b572b6facae5023fac28dafe9a659a93f0cb56ef2762f84b85959358ee9a33be687b1 SHA512 5e89906d4df0890d61ddca9cc88549acac6c94fc7267975a0ad8684855283c60a2f5fbd48051569c33fa513b6c25485d474446066911577f8cad00c26b57cd43
+EBUILD bigdecimal-3.1.4.ebuild 1013 BLAKE2B 836d4ce777f040d5f74bf5995f1c784f824e75ec9d8b49a4ae7b6cc5fc66b57bd27fb5fa64734be5c03f6e9611ca0e7416708f4af97dab336125e65511f419aa SHA512 1b2c3fe083a76d67d927070b24f1db6e64a13d5c68c555b2e7ab8fa6594610faef1bb98de7ed0e05e3e21e4e8d2740c725ee03b33d09dbe9b7812df531306cdd
+MISC metadata.xml 342 BLAKE2B 84d396ff1ab37dc1514237f99ad59f87b12fda2a22a6374c92186d34f2559e14f4a51a6832e5501fa13b0f0c4fd7587fd4afc3f3ddc8f4fb3b02738657e6c1fb SHA512 f834c875eea544b4aef0b56c5091a15cf2b09469c336ebbac704b023c15af45de21c02961be5fc3a64923c7c099eade2c5abeaf447939c3c9c1903cb305b0121
diff --git a/dev-ruby/bigdecimal/bigdecimal-3.1.4.ebuild b/dev-ruby/bigdecimal/bigdecimal-3.1.4.ebuild
new file mode 100644
index 000000000000..4370cfc03906
--- /dev/null
+++ b/dev-ruby/bigdecimal/bigdecimal-3.1.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTENSIONS=(ext/bigdecimal/extconf.rb)
+RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
+RUBY_FAKEGEM_GEMSPEC="bigdecimal.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Arbitrary-precision decimal floating-point number library for Ruby"
+HOMEPAGE="https://github.com/ruby/bigdecimal"
+SRC_URI="https://github.com/ruby/bigdecimal/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( Ruby-BSD BSD-2 )"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+SLOT="0"
+IUSE="test"
+
+all_ruby_prepare() {
+ sed -e '/^source_version/,/^end/ s:^:#:' \
+ -e "/s.version/ s/= source_version/= '${PV}'/" \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test:. -rtest/lib/helper -e "Dir['test/**/test_*.rb'].each { require _1 }" || die
+}
diff --git a/dev-ruby/bigdecimal/metadata.xml b/dev-ruby/bigdecimal/metadata.xml
new file mode 100644
index 000000000000..2df3a2ecd5cf
--- /dev/null
+++ b/dev-ruby/bigdecimal/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ruby/bigdecimal</remote-id>
+ </upstream>
+</pkgmetadata>