summaryrefslogtreecommitdiff
path: root/dev-ruby/bcrypt-ruby
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/bcrypt-ruby
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/bcrypt-ruby')
-rw-r--r--dev-ruby/bcrypt-ruby/Manifest5
-rw-r--r--dev-ruby/bcrypt-ruby/bcrypt-ruby-3.1.11-r1.ebuild59
-rw-r--r--dev-ruby/bcrypt-ruby/bcrypt-ruby-3.1.12.ebuild59
-rw-r--r--dev-ruby/bcrypt-ruby/metadata.xml11
4 files changed, 134 insertions, 0 deletions
diff --git a/dev-ruby/bcrypt-ruby/Manifest b/dev-ruby/bcrypt-ruby/Manifest
new file mode 100644
index 000000000000..59c9cb49bdd1
--- /dev/null
+++ b/dev-ruby/bcrypt-ruby/Manifest
@@ -0,0 +1,5 @@
+DIST bcrypt-3.1.11.gem 44032 BLAKE2B debdc199ff3806b32998c91a99006f293ca6ebbfe2573546afda7c705fbdc0ac8f4cdfba97c1765668cfe3782cb4f9affff1b59b20c42e19fd14a6fa52f66160 SHA512 bf9ff0d3cdd7044b4ee5796cd04869f21bb3384143b0f336bc2cd9a8f0db3f9562aa23a39601c1d86f153b62f07469ef066616f8a52cfcd840377e331cb22454
+DIST bcrypt-3.1.12.gem 44544 BLAKE2B 767d38c3fc03e24bedc6a14668538d214219b93fed0b918dedfd5aabc25cd46273e0f7a849dbfa8d23e4ace2ec037809dcd927a9942bfcc126def7e707252c39 SHA512 1cb465bc00e40c82c7b9789cf5ba96273a455f4c1c993f411a9b80d39aa9c938e4909a094ca92af786ad3cd836eebac2aefcbe1bb29c6238947e55fcdc110d35
+EBUILD bcrypt-ruby-3.1.11-r1.ebuild 1632 BLAKE2B dbcd215a7168f7b3db6d64b07df88e5827698043ee6af3c147a02d178c1ecce02a6cf359525e36ea65c545dea923c14bf185776ea82b84e0e3fdc2dcb41b3a97 SHA512 b5246d4420931b77c58d3ede50e039b461047fd28b605d8a887ba12ae1e7ad8c88bf4a192eb16a7def6a7f6902f4674f38e0dbaf12670c5edb2dc6d7fcb54062
+EBUILD bcrypt-ruby-3.1.12.ebuild 1633 BLAKE2B 8ffb6fe0b7ffb5a7b8df01322fd8b2d17d97089054b0cdbd53043a4300a29c2f4fdb234f88ab486b8447152f8e4c79cdce408a889b32bab649f5b09295a9fca3 SHA512 78eeb4f949f26ede91c6ae6afa1151384f3ce878b07457209678d3f5147744a9d6419161f19e89359bb68b46cce742763079911752892a4c711e428dc35e7eaa
+MISC metadata.xml 346 BLAKE2B 635b8241d82a243f102d3ee6ce24c6cb183a9decd70cb02ee8734c85c9796b3dad0206b4e18da86df0e68fdc72a782b0494d682e757631718d0d60ee27b3d67f SHA512 ade206e8719923e0e758268c757100148580fd817bf477beee8df9b9b9f99a50b82b898e555bb6b0fd91239af22b1d7aa320caa1fed5c093a8799e82fac97608
diff --git a/dev-ruby/bcrypt-ruby/bcrypt-ruby-3.1.11-r1.ebuild b/dev-ruby/bcrypt-ruby/bcrypt-ruby-3.1.11-r1.ebuild
new file mode 100644
index 000000000000..3c7e313f372d
--- /dev/null
+++ b/dev-ruby/bcrypt-ruby/bcrypt-ruby-3.1.11-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.md"
+
+RUBY_FAKEGEM_NAME="bcrypt"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="An easy way to keep your users' passwords secure"
+HOMEPAGE="https://github.com/codahale/bcrypt-ruby"
+LICENSE="MIT"
+
+KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -i -e '/git ls-files/d' bcrypt.gemspec || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/mri extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -Cext/mri V=1
+ cp ext/mri/*$(get_modname) lib/ || die
+}
+
+each_ruby_install() {
+ each_fakegem_install
+
+ # bcrypt was called bcrypt-ruby before, so add a spec file that
+ # simply loads bcrypt to make sure that old projects load correctly
+ # we don't even need to create a file to load this: the `require
+ # bcrypt` was already part of bcrypt-ruby requirements.
+ cat - <<EOF > "${T}/bcrypt-ruby.gemspec"
+Gem::Specification.new do |s|
+ s.name = "bcrypt-ruby"
+ s.version = "${RUBY_FAKEGEM_VERSION}"
+ s.summary = "Fake gem to load bcrypt"
+ s.homepage = "${HOMEPAGE}"
+ s.specification_version = 3
+ s.add_runtime_dependency("${RUBY_FAKEGEM_NAME}", ["= ${RUBY_FAKEGEM_VERSION}"])
+end
+EOF
+ RUBY_FAKEGEM_NAME=bcrypt-ruby \
+ RUBY_FAKEGEM_GEMSPEC="${T}/bcrypt-ruby.gemspec" \
+ ruby_fakegem_install_gemspec
+}
diff --git a/dev-ruby/bcrypt-ruby/bcrypt-ruby-3.1.12.ebuild b/dev-ruby/bcrypt-ruby/bcrypt-ruby-3.1.12.ebuild
new file mode 100644
index 000000000000..4680bb999ff2
--- /dev/null
+++ b/dev-ruby/bcrypt-ruby/bcrypt-ruby-3.1.12.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.md"
+
+RUBY_FAKEGEM_NAME="bcrypt"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="An easy way to keep your users' passwords secure"
+HOMEPAGE="https://github.com/codahale/bcrypt-ruby"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -i -e '/git ls-files/d' bcrypt.gemspec || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/mri extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -Cext/mri V=1
+ cp ext/mri/*$(get_modname) lib/ || die
+}
+
+each_ruby_install() {
+ each_fakegem_install
+
+ # bcrypt was called bcrypt-ruby before, so add a spec file that
+ # simply loads bcrypt to make sure that old projects load correctly
+ # we don't even need to create a file to load this: the `require
+ # bcrypt` was already part of bcrypt-ruby requirements.
+ cat - <<EOF > "${T}/bcrypt-ruby.gemspec"
+Gem::Specification.new do |s|
+ s.name = "bcrypt-ruby"
+ s.version = "${RUBY_FAKEGEM_VERSION}"
+ s.summary = "Fake gem to load bcrypt"
+ s.homepage = "${HOMEPAGE}"
+ s.specification_version = 3
+ s.add_runtime_dependency("${RUBY_FAKEGEM_NAME}", ["= ${RUBY_FAKEGEM_VERSION}"])
+end
+EOF
+ RUBY_FAKEGEM_NAME=bcrypt-ruby \
+ RUBY_FAKEGEM_GEMSPEC="${T}/bcrypt-ruby.gemspec" \
+ ruby_fakegem_install_gemspec
+}
diff --git a/dev-ruby/bcrypt-ruby/metadata.xml b/dev-ruby/bcrypt-ruby/metadata.xml
new file mode 100644
index 000000000000..7b40466101e9
--- /dev/null
+++ b/dev-ruby/bcrypt-ruby/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">codahale/bcrypt-ruby</remote-id>
+ </upstream>
+</pkgmetadata>