summaryrefslogtreecommitdiff
path: root/dev-ruby/bcat/bcat-0.6.2-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ruby/bcat/bcat-0.6.2-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ruby/bcat/bcat-0.6.2-r2.ebuild')
-rw-r--r--dev-ruby/bcat/bcat-0.6.2-r2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-ruby/bcat/bcat-0.6.2-r2.ebuild b/dev-ruby/bcat/bcat-0.6.2-r2.ebuild
new file mode 100644
index 000000000000..122859ad9662
--- /dev/null
+++ b/dev-ruby/bcat/bcat-0.6.2-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_TASK_DOC="man"
+RUBY_FAKEGEM_EXTRADOC="README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Pipe to browser utility for use at the shell and within editors"
+HOMEPAGE="https://github.com/rtomayko/bcat"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 ~sparc x86 ~x86-fbsd"
+IUSE=""
+
+# Collides on /usr/bin/bcat, bug 418301
+RDEPEND="${RDEPEND} !!<app-accessibility/speech-tools-2.1-r3"
+
+ruby_add_bdepend "doc? ( app-text/ronn )
+ test? ( dev-ruby/test-unit:2 )"
+
+ruby_add_rdepend "dev-ruby/rack:*"
+
+each_ruby_prepare() {
+ sed -i -e "s/a2h/#{ENV['RUBY']} -S a2h/" test/test_bcat_a2h.rb || die
+}
+
+each_ruby_test() {
+ # The Rakefile uses weird trickery with load path that causes gems
+ # not to be found. Run tests directly instead and do the trickery
+ # here to support popen calls for the bins in this package.
+ RUBY=${RUBY} RUBYLIB=lib:${RUBYLIB} PATH=bin:${PATH} ${RUBY} -S testrb-2 test/test_*.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman man/*.1
+}