summaryrefslogtreecommitdiff
path: root/dev-ruby/atomic
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/atomic
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/atomic')
-rw-r--r--dev-ruby/atomic/Manifest7
-rw-r--r--dev-ruby/atomic/atomic-1.1.100.ebuild33
-rw-r--r--dev-ruby/atomic/atomic-1.1.101.ebuild33
-rw-r--r--dev-ruby/atomic/atomic-1.1.99.ebuild33
-rw-r--r--dev-ruby/atomic/metadata.xml11
5 files changed, 117 insertions, 0 deletions
diff --git a/dev-ruby/atomic/Manifest b/dev-ruby/atomic/Manifest
new file mode 100644
index 000000000000..a54034fc3de1
--- /dev/null
+++ b/dev-ruby/atomic/Manifest
@@ -0,0 +1,7 @@
+DIST atomic-1.1.100.gem 17920 BLAKE2B 47c96c49a572a6d6705b952e419e1a07f3b06de4e0235a4d9d98e6ff546c96aa9af69c39864107c6bec1ba7b92ca2a9ceef2cb5d5938c1c82f40973376920d6e SHA512 64c374b69b7ea8b7fc6aa3e189cb6ae3d4a9a214d410a83fa0ef464a55624792055c5e3e61adda3eff039aba604a0c1b710ba5304d33f27ae9cc6e421e8e1892
+DIST atomic-1.1.101.gem 17920 BLAKE2B 50f4efc215293e931380b6307231279b3c5ca055aa8082fee8575963a68b3d54262449bf45fb1a514dab18f53a1dd9e0467a0f7ac67dea7a45fcce09155721dd SHA512 59c82fa5ec984b7ecd97964ea075ea327511fd4e71cc5ac72d3fb573b777c9fb289f462d022ea1e0256b38dc369c9f7fa7a61b7af877bd06ec94252237111e8d
+DIST atomic-1.1.99.gem 17920 BLAKE2B 814406dc3e38a3ec882eb47e20e6153da9f68c4dd6ba3bc3d3869c0542754ba38678512872b25379b12d902ad6f740b1da974680867d492d2c4620091c5a32c9 SHA512 9c7762f6c32d11b2c5b45be68954ca12c753d2b4683167158a037ce791d72b13d940beef5bf6dd445c8b12e358c62d2a9f43a609fb3b7c7357fea4f66316063c
+EBUILD atomic-1.1.100.ebuild 772 BLAKE2B 20b30483123fe5e082f7f6e373e40b04693a5d4f232f956e186559c7fde98d9793ef8b6e293b924e324cc7a0c5370f16c767e056249681b1f75d9a7dfb7a79dd SHA512 7bd017d22401a6c9f5b56943bd9cb5fcb2e175d1f7d4bbb6ac997347c9bad88eba9e587a82d3f48b40030d1680fb47aa5ca763dedffe50b7a7c64362422330a7
+EBUILD atomic-1.1.101.ebuild 760 BLAKE2B 52e09ad11910b8d8810ff494109424412c791d64ace59623aecbe14b5ce34a012952d3bfecc07c7eb74d63cec2b13fb5068194cd8261ba748a7170e353edf963 SHA512 8a85606f8d9855b34cab062c7d658cd9338bab6846bc0a88d885e8db36e1f277aaa0739e9d42ab99a65b6e4e8d128c74dd09575a213682b9cfc0f2489b4f5295
+EBUILD atomic-1.1.99.ebuild 769 BLAKE2B 72539198e33799e07965a974e4e96afe6494e749380fa0fd3b9f34b4eae5bbf440b001087c58fc11c9dc222f3427e639e1bbf4afece065f8521fb3577e7d3b51 SHA512 6e33377ff01b28431bdac42ab33a879ef4bb894ede658e4525439dd32031f1594d4b719cf170a35ac153837fe47f083a116a5eecf911352a8c96ca73043f7e2d
+MISC metadata.xml 345 BLAKE2B 64598e451aa2d3e6225aed11977f43d379ad3d26c0f6366dfee9651544e3c4d565a342d61fd1a2f0d176a5cd0e5f97ad1ae5c1150d97a24ff3472e49eb30d446 SHA512 2fc1039a507f87fab12c537d790d538c6e9abada720edcf9de3748e5d81674f4803221ec940a7f3abc6b12f7c9ec009a2960d88e00b45caf2216a23263e03f8f
diff --git a/dev-ruby/atomic/atomic-1.1.100.ebuild b/dev-ruby/atomic/atomic-1.1.100.ebuild
new file mode 100644
index 000000000000..811158c883e2
--- /dev/null
+++ b/dev-ruby/atomic/atomic-1.1.100.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="An atomic reference implementation for JRuby, Rubinius, and MRI"
+HOMEPAGE="https://github.com/headius/ruby-atomic"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ # Avoid compilation dependencies since we compile directly.
+ sed -i -e '/:test => :compile/ s:^:#:' \
+ -e '/extensiontask/,/end/ s:^:#:' Rakefile || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext
+ cp ext/atomic_reference$(get_modname) lib/ || die
+}
diff --git a/dev-ruby/atomic/atomic-1.1.101.ebuild b/dev-ruby/atomic/atomic-1.1.101.ebuild
new file mode 100644
index 000000000000..a7c394c0b3f9
--- /dev/null
+++ b/dev-ruby/atomic/atomic-1.1.101.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="An atomic reference implementation for JRuby, Rubinius, and MRI"
+HOMEPAGE="https://github.com/headius/ruby-atomic"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~arm64 hppa ppc ppc64 x86"
+IUSE=""
+
+all_ruby_prepare() {
+ # Avoid compilation dependencies since we compile directly.
+ sed -i -e '/:test => :compile/ s:^:#:' \
+ -e '/extensiontask/,/end/ s:^:#:' Rakefile || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext
+ cp ext/atomic_reference$(get_modname) lib/ || die
+}
diff --git a/dev-ruby/atomic/atomic-1.1.99.ebuild b/dev-ruby/atomic/atomic-1.1.99.ebuild
new file mode 100644
index 000000000000..b70c62957f02
--- /dev/null
+++ b/dev-ruby/atomic/atomic-1.1.99.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="An atomic reference implementation for JRuby, Rubinius, and MRI"
+HOMEPAGE="https://github.com/headius/ruby-atomic"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ppc ~ppc64 x86"
+IUSE=""
+
+all_ruby_prepare() {
+ # Avoid compilation dependencies since we compile directly.
+ sed -i -e '/:test => :compile/ s:^:#:' \
+ -e '/extensiontask/,/end/ s:^:#:' Rakefile || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext
+ cp ext/atomic_reference$(get_modname) lib/ || die
+}
diff --git a/dev-ruby/atomic/metadata.xml b/dev-ruby/atomic/metadata.xml
new file mode 100644
index 000000000000..a478e049f78f
--- /dev/null
+++ b/dev-ruby/atomic/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">headius/ruby-atomic</remote-id>
+ </upstream>
+</pkgmetadata>