summaryrefslogtreecommitdiff
path: root/dev-ruby/ast
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/ast
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/ast')
-rw-r--r--dev-ruby/ast/Manifest5
-rw-r--r--dev-ruby/ast/ast-2.3.0.ebuild31
-rw-r--r--dev-ruby/ast/ast-2.4.0.ebuild31
-rw-r--r--dev-ruby/ast/metadata.xml11
4 files changed, 78 insertions, 0 deletions
diff --git a/dev-ruby/ast/Manifest b/dev-ruby/ast/Manifest
new file mode 100644
index 000000000000..a78fd0f1e81c
--- /dev/null
+++ b/dev-ruby/ast/Manifest
@@ -0,0 +1,5 @@
+DIST ast-2.3.0.gem 14848 BLAKE2B 141aa3fd01bfd9d7c1b82ff20cab9243322c70f69ee54026ec121c5491fdfca1c00eae293c631c67b0c12b0ba9aeadcf3756a9cbe2a05cfa7c89a8acda48d188 SHA512 7b814517075a5f4607cab24e1c20747c7def1d818e6df95205eaad2152952a38cd551bff5f0d59979fd8c6cb7dfa6bc9830541257bb3a24927217fd84526d58f
+DIST ast-2.4.0.gem 15360 BLAKE2B 1d68fa8137bf2a158e8b2e0f30d3d803791db7fcb397133681cd2ffb57badebe6f9afd792a7cf3907dc1fa3e3a617fbb0331c85c69e36a46ca49962f30be9979 SHA512 60a0b00103ed57c71907155ee7966127985021e51c1d829e2149c87066504e76fdb955f9717bb19b5627d5b8c44f0d6a165e208900ede2355a47970ee9664b72
+EBUILD ast-2.3.0.ebuild 703 BLAKE2B de64826b497d003d6a657ad35bbd01e8c88be7e0836dddb7195c35ca11c85168016de967d26176be462c70da5099da5a467edf46492899ad24982e28c60de26e SHA512 a3d8192dd239548a7fcd44bf40227659b86f997503a3f8bc70c7bf08581fe136d4e721ff6cd26d780b9f9868bd70b9cb00a788ae34bcb1bb126011af24138bb9
+EBUILD ast-2.4.0.ebuild 703 BLAKE2B 75a60dbc26cc730c9e4e36fd177a04fd2391e6daa7b38a8c47f63ab50f6441efb013cbdbfc0fbc06389a8c13e4808134adc60265d1d358503e794ebc0a7242e7 SHA512 2b4d266f4ea4e6c51501626101ae3ab1f6851298da24cd17ce17803b2038621e704e608c6d4d66b3f382c52cf5fb626d1c47effdafb4f44fbd342c34065aa6ca
+MISC metadata.xml 340 BLAKE2B 30aec3a2478894cc3d10da2ff828e275c0400061f0fcf123131501a55ca56355e9af3fd0d53bf5edbbd4e5953a426fd68ba1b912771f66bedd9a2c61c335ca58 SHA512 cb57a981e9698ea62d17dbb519c215e420d9fbc791ef3d98394202909beacfaae2bc425332febaae18d9966b3586e82c52f60cd442f9cdb9b4f2abc25ba7b86e
diff --git a/dev-ruby/ast/ast-2.3.0.ebuild b/dev-ruby/ast/ast-2.3.0.ebuild
new file mode 100644
index 000000000000..699c86637039
--- /dev/null
+++ b/dev-ruby/ast/ast-2.3.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A library for working with abstract syntax trees"
+HOMEPAGE="https://github.com/whitequark/ast"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "test? (
+ dev-ruby/bacon )"
+
+all_ruby_prepare() {
+ sed -i -e "/[Bb]undler/d" Rakefile || die
+ sed -i -e "/git ls/d" ${PN}.gemspec || die
+ sed -i -e "/simplecov/,+11d" -e "/colored_output/d" test/helper.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -S bacon -Itest -a || die
+}
diff --git a/dev-ruby/ast/ast-2.4.0.ebuild b/dev-ruby/ast/ast-2.4.0.ebuild
new file mode 100644
index 000000000000..3f3bb140d306
--- /dev/null
+++ b/dev-ruby/ast/ast-2.4.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A library for working with abstract syntax trees"
+HOMEPAGE="https://github.com/whitequark/ast"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "test? (
+ dev-ruby/bacon )"
+
+all_ruby_prepare() {
+ sed -i -e "/[Bb]undler/d" Rakefile || die
+ sed -i -e "/git ls/d" ${PN}.gemspec || die
+ sed -i -e "/simplecov/,+11d" -e "/colored_output/d" test/helper.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -S bacon -Itest -a || die
+}
diff --git a/dev-ruby/ast/metadata.xml b/dev-ruby/ast/metadata.xml
new file mode 100644
index 000000000000..9f302626b67a
--- /dev/null
+++ b/dev-ruby/ast/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">whitequark/ast</remote-id>
+ </upstream>
+</pkgmetadata>