summaryrefslogtreecommitdiff
path: root/dev-ruby/asciimath
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/asciimath
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/asciimath')
-rw-r--r--dev-ruby/asciimath/Manifest4
-rw-r--r--dev-ruby/asciimath/asciimath-1.0.4.ebuild22
-rw-r--r--dev-ruby/asciimath/files/asciimath-1.0.4-backslashes.patch22
-rw-r--r--dev-ruby/asciimath/metadata.xml11
4 files changed, 59 insertions, 0 deletions
diff --git a/dev-ruby/asciimath/Manifest b/dev-ruby/asciimath/Manifest
new file mode 100644
index 000000000000..9b0e74bb3ccf
--- /dev/null
+++ b/dev-ruby/asciimath/Manifest
@@ -0,0 +1,4 @@
+AUX asciimath-1.0.4-backslashes.patch 1246 BLAKE2B b34cfc0ac9fc57780ce24e6aec242c19bb667b254c95eb306093d94dd0b1d8554e23911e74ba1f595622dc2533af0d9002108a2fcb502acb38ebc0a1d71c41b0 SHA512 3c5ea019fc0d1c71b156dc9a6263211cb1bd3c69c4b9c390f1c3d10a4504e281e7cacaca68efa7daeae6af1327931ff99124c8c498eab9a8a04d6313ea1260d7
+DIST asciimath-1.0.4.gem 14336 BLAKE2B 84aac2d2b987f72a17288cee6d00197c429e04c216fad62ecd23b5f3eebe9590ead519df86cdaf99246dcfee4c18bab67176a0d47a1b864de6e44bdb4b90b70c SHA512 e99e6f869dda3e0236392039e6dccf5912b095e32ee7acbfb4684a5d723d05f4d3c9961554d5beab2a3d703b1ef50c45ed15c0dbda2179ab35d3b1b6b8759b49
+EBUILD asciimath-1.0.4.ebuild 532 BLAKE2B bfbcb5e1e5913beb328aebbd24cfbff7878e8020c284c9486adc39c0ac26a23a61baec00ad40de4308a3d4f48ff7e7ffdef52d3a19a7ae9095759e9dbdbe04b3 SHA512 ad5633bc2670e4f824c309f316df11f6b6c1b5a63a9ed81f444789e86d69f5adbe28754d032ea3442a113284cd4b5905ad79089f30c174a14a26f64002a494d6
+MISC metadata.xml 344 BLAKE2B 7979667ff10553d0f1c80a34a03bca56057a4dcf856440b9f9bc4ea64aa018da426601b76dff578625481cb51f7384c7716a3aa98670f178c4209ad39a9af9d9 SHA512 606dd415c7a141188cc94a7d56c67d42be1c2420f8ba9ee7a44707b99a6035df1cd8d358de575e12008f0560aa2b87b57b5892c67f3d931aa28c5938373a8075
diff --git a/dev-ruby/asciimath/asciimath-1.0.4.ebuild b/dev-ruby/asciimath/asciimath-1.0.4.ebuild
new file mode 100644
index 000000000000..6bb8e872efad
--- /dev/null
+++ b/dev-ruby/asciimath/asciimath-1.0.4.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.adoc README.adoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A pure Ruby AsciiMath parsing and conversion library"
+HOMEPAGE="https://github.com/pepijnve/asciimath"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="amd64 arm ~arm64 ~hppa ppc ppc64 ~sparc x86"
+IUSE=""
+
+RUBY_PATCHES=( ${P}-backslashes.patch )
diff --git a/dev-ruby/asciimath/files/asciimath-1.0.4-backslashes.patch b/dev-ruby/asciimath/files/asciimath-1.0.4-backslashes.patch
new file mode 100644
index 000000000000..9bf08ce34046
--- /dev/null
+++ b/dev-ruby/asciimath/files/asciimath-1.0.4-backslashes.patch
@@ -0,0 +1,22 @@
+From 1c06fdc8086077f4785479f78b0823a4a72d7948 Mon Sep 17 00:00:00 2001
+From: Pepijn Van Eeckhoudt <pepijn@vaneeckhoudt.net>
+Date: Thu, 12 May 2016 18:02:45 +0200
+Subject: [PATCH] Remove spurious backslashes
+
+---
+ spec/parser_spec.rb | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/spec/parser_spec.rb b/spec/parser_spec.rb
+index def78e0..3fa5a75 100644
+--- a/spec/parser_spec.rb
++++ b/spec/parser_spec.rb
+@@ -45,7 +45,7 @@
+ '"Скорость"=("Расстояние")/("Время")' =>
+ '<math><mtext>Скорость</mtext><mo>=</mo><mfrac><mtext>Расстояние</mtext><mtext>Время</mtext></mfrac></math>',
+ 'bb (a + b) + cc c = fr (d^n)' =>
+- '<math><mstyle mathvariant=\"bold\"><mrow><mi>a</mi><mo>+</mo><mi>b</mi></mrow></mstyle><mo>+</mo><mstyle mathvariant=\"script\"><mi>c</mi></mstyle><mo>=</mo><mstyle mathvariant=\"fraktur\"><msup><mi>d</mi><mi>n</mi></msup></mstyle></math>'
++ '<math><mstyle mathvariant="bold"><mrow><mi>a</mi><mo>+</mo><mi>b</mi></mrow></mstyle><mo>+</mo><mstyle mathvariant="script"><mi>c</mi></mstyle><mo>=</mo><mstyle mathvariant="fraktur"><msup><mi>d</mi><mi>n</mi></msup></mstyle></math>'
+ }
+
+ version = RUBY_VERSION.split('.').map { |s| s.to_i }
diff --git a/dev-ruby/asciimath/metadata.xml b/dev-ruby/asciimath/metadata.xml
new file mode 100644
index 000000000000..87c3111c694b
--- /dev/null
+++ b/dev-ruby/asciimath/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">pepijnve/asciimath</remote-id>
+ </upstream>
+</pkgmetadata>