summaryrefslogtreecommitdiff
path: root/dev-ruby/asciidoctor-diagram
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-09 16:33:39 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-09 16:33:39 +0100
commit785047acce64d1217286105397cc6fe433c34cb3 (patch)
tree714041fe6d930b5e1c4f005d501fdb914c4834b5 /dev-ruby/asciidoctor-diagram
parent6440e1dd038e7df4f9df7dd5127d3b1c6f39034e (diff)
gentoo auto-resync : 09:09:2023 - 16:33:38
Diffstat (limited to 'dev-ruby/asciidoctor-diagram')
-rw-r--r--dev-ruby/asciidoctor-diagram/Manifest2
-rw-r--r--dev-ruby/asciidoctor-diagram/asciidoctor-diagram-2.2.11.ebuild53
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-ruby/asciidoctor-diagram/Manifest b/dev-ruby/asciidoctor-diagram/Manifest
index 078c5afaf633..9743fdb9eab5 100644
--- a/dev-ruby/asciidoctor-diagram/Manifest
+++ b/dev-ruby/asciidoctor-diagram/Manifest
@@ -1,3 +1,5 @@
DIST asciidoctor-diagram-2.0.5.tar.gz 12482984 BLAKE2B b0ef8596d2f2dfcf11fcbba876141aee38e8615195159f76e07b45c00b46bd85824dd6e8e9f571b396bbd9d082c5d60d4e05cdeac27719bfca53216c0d1b1816 SHA512 7e3bfbfb08d7389a039b1727bc173fca82e05134bebd89f3ca65d5e7860555034ff5e785c32e55ea2cc9826343456c6ecdfa15fc76f4d94858461356ab3ced71
+DIST asciidoctor-diagram-2.2.11.tar.gz 15488606 BLAKE2B e0080ecafafcaef72ae1ca449d4ea2d4b69b1550d62cacb514350da047952adbddc0c9f48081fe7acae7f174c6b910c297357ef57df09c0c5a379a3332eb38e8 SHA512 233d2940516fa28863e53b7e4f43851256fdcc83e92fc5d4eafdc2e820a8040473c89f7f01397bdb26b6c4fbd9e6fcb576156c4abd949660ade37d152c8e5e40
EBUILD asciidoctor-diagram-2.0.5-r1.ebuild 1219 BLAKE2B 61342fe4386b43966a3086a568023278129be9270502cacb70bb7a4ca77dd57c623f8fc6a6f96a9ed5788d66ff53e6249c7b299d6df1a0c6744174ea6251441e SHA512 57bde827d63c7f7b9cf29e914491f81d75fb3af96740faff7f94f5d275893259fdb6a4705ea79e3fb43b202732e7f45c826d4cb2702d8b0f3022896bbcc459eb
+EBUILD asciidoctor-diagram-2.2.11.ebuild 1546 BLAKE2B fc915ee30e0656461d799faf558761fa1002417285c26848126da24c675d9e640e6b6b2363893dcfcca4b39c413bc3019ccddeafd0028158eae1e5b5112d2bdd SHA512 a781fad331baa1808eddeedda56ada4bfb5a0b473720383d1bbfcd24bdccf0c4fea08a03d3bab733e7dcb66c3a507e6101e4d21511faee40a4f0254fb9f2616b
MISC metadata.xml 358 BLAKE2B 0a7ccfa951823c5c42d8ce280483f15e73abaf453c24b79b68bce29717bb3ae4e4656f40d7bc320479e65d8942bf43cb4abca9b9d916d2c27275880ef2034367 SHA512 4cb3cea3081700e1eb920452d2408fbf7ef730232e2979edc057c10b1ff879d14d97914765c644fc8d055c5705b8bb16b2a9651001733b102b8a05a1e72e1cdb
diff --git a/dev-ruby/asciidoctor-diagram/asciidoctor-diagram-2.2.11.ebuild b/dev-ruby/asciidoctor-diagram/asciidoctor-diagram-2.2.11.ebuild
new file mode 100644
index 000000000000..cb24f379e007
--- /dev/null
+++ b/dev-ruby/asciidoctor-diagram/asciidoctor-diagram-2.2.11.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.adoc LICENSE.txt README.adoc"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A set of Asciidoctor extensions that enable you to add diagrams"
+HOMEPAGE="https://github.com/asciidoctor/asciidoctor-diagram"
+SRC_URI="https://github.com/asciidoctor/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND+=" virtual/jre"
+DEPEND+=" test? (
+ dev-texlive/texlive-latex
+ dev-texlive/texlive-latexextra
+ media-gfx/imagemagick[png,postscript]
+ media-gfx/graphviz
+ media-sound/lilypond
+ sci-visualization/gnuplot
+)"
+ruby_add_rdepend ">=dev-ruby/asciidoctor-1.5.7 <dev-ruby/asciidoctor-3"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -e '/c.formatter/ s:^:#:' \
+ -e '/logger.*DEBUG/ s:^:#:' \
+ -i spec/test_helper_methods.rb || die
+
+ # Remove some diagram dependencies that contains vendored code and
+ # are currently not packaged. Please file a bug if you have a need
+ # for these diagram types.
+ sed -i -e '/\(ditaamini\|plantuml\)/ s:^:#:' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Avoid specs for unpackaged tools
+ rm -f spec/{a2s,barcode,blockdiag,bpmn,bytefield,d2,dbml,diagrams,ditaa,dpic,erd,graphviz_py,mermaid,msc,nomnoml,pikchr,plantuml,shaape,smcat,structurizr,svgbob,symbolator,syntrax,umlet,vega,wavedrom}_spec.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+}