summaryrefslogtreecommitdiff
path: root/dev-ruby/asciidoctor-diagram
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-08 10:50:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-08 10:50:14 +0100
commit3f71901f8c228f4de570abed1831ce3ee425343e (patch)
treea2dcd300d05ef8a2ec275b44a92a9d85bd3baa24 /dev-ruby/asciidoctor-diagram
parent12bb627384ddfd47382b9f1b6464481a58d01ebb (diff)
gentoo resync 08.09.2018
Diffstat (limited to 'dev-ruby/asciidoctor-diagram')
-rw-r--r--dev-ruby/asciidoctor-diagram/Manifest2
-rw-r--r--dev-ruby/asciidoctor-diagram/asciidoctor-diagram-1.5.10.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-ruby/asciidoctor-diagram/Manifest b/dev-ruby/asciidoctor-diagram/Manifest
index 89bd18817309..8f640949cdd7 100644
--- a/dev-ruby/asciidoctor-diagram/Manifest
+++ b/dev-ruby/asciidoctor-diagram/Manifest
@@ -1,3 +1,5 @@
+DIST asciidoctor-diagram-1.5.10.tar.gz 10441267 BLAKE2B e5adfa51ecdf966d471c9adb8ee6a99e5a208b4934646a1f0d672fd29b69cf59eefdee90444b0b99ff3c91172c99b9f41768ad7f4edf7ec203416c47b46d7e88 SHA512 fcf76d71d0b9d58dc5a01aa484faa663f636ff36f534c43621a71702032d1f49a04189d0ffaff8b0fdc2f189d54ce7392f74e1b0f29128fc3180e48d35bed5b1
DIST asciidoctor-diagram-1.5.9.tar.gz 10250161 BLAKE2B ebeb184259042a9088c5a8f6c5afc86a69f6fcea62964ac2f571f21b6b2b382cdf2cad8abc1e99ca781b4663da956982f1a5d418126089b17bac0e68bdce0fea SHA512 b25f5c2b8ddfc2b9bdc26ef47b5a2ae8d28992ac26f70ccc4c9046a45e9338b5ed2b82cccb0f01dd44155e043b620410b468ef6b12dfe03ae20a67e4d109be05
+EBUILD asciidoctor-diagram-1.5.10.ebuild 949 BLAKE2B 00192b5b184f14a83a00d927b1c7b27e2755d95ed41cfe72d6c02bec80431c36bcb871b77db7080bca0d6ada04db6194c4bc016a71f57857d53844d4565b65f6 SHA512 b7a1e0ea65d642ab617b2c294375830bb3f67d9b09c3a5e2eaf6ab33c55b8154d4e1075e8646c28c2ecb8b21b8f197fbb39479525292d147d91e91b444ee3088
EBUILD asciidoctor-diagram-1.5.9.ebuild 956 BLAKE2B f7cd62ebf9d728612cb90d7eae6314c9f9e94cd40d3e6bdf27b65bfcf74efd70cacd359c2689cd1d4fb9abb47c1137a2e26b65de4894accc1076031c1249035e SHA512 025151cc864febfb45323c1d5eec8d2ecac8e6fa48cc168a235a9fb38c38824caf4c74ad3256f64aa00176e68454d192ead807e93745cc5c3085080c3b5c749e
MISC metadata.xml 357 BLAKE2B 967e1f1518c38ff81d15df5b62943b278acf74a80938d488cca0d2489f268ba0d41ad74e78b7b53bc1fd4ed646880ed36defc9c110d5af3535970c364d8c923b SHA512 711af8ceb9724236076e02a077672296a835981c7a78e4f5f5976dc190b2df640d24933cc2d92e81f84e695f473d187a7e83d2b60c3573a675ba30b01be85db8
diff --git a/dev-ruby/asciidoctor-diagram/asciidoctor-diagram-1.5.10.ebuild b/dev-ruby/asciidoctor-diagram/asciidoctor-diagram-1.5.10.ebuild
new file mode 100644
index 000000000000..52d3bea3bbd3
--- /dev/null
+++ b/dev-ruby/asciidoctor-diagram/asciidoctor-diagram-1.5.10.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.adoc LICENSE.txt README.adoc"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="A set of Asciidoctor extensions that enable you to add diagrams"
+HOMEPAGE="https://github.com/asciidoctor/asciidoctor-diagram"
+SRC_URI="https://github.com/asciidoctor/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "=dev-ruby/asciidoctor-1.5*"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -i -e '/c.formatter/ s:^:#:' spec/test_helper.rb || die
+
+ # Avoid specs for unpackaged tools
+ rm -f spec/{a2s,blockdiag,erd,mermaid,msc,shaape,svgbob,syntrax,umlet,vega,wavedrom}_spec.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+}