summaryrefslogtreecommitdiff
path: root/dev-ruby/amqp/amqp-1.8.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-03 19:17:21 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-03 19:17:21 +0000
commit81e4fbcb846ed1cabdad699c0029b166dd7273b7 (patch)
tree16f1236b7a386949c02a6e3c13d0fcd8298fa133 /dev-ruby/amqp/amqp-1.8.0.ebuild
parenta70f42c65202d88c203c40910fef8f96f333d1ee (diff)
gentoo resync : 03.01.2018
Diffstat (limited to 'dev-ruby/amqp/amqp-1.8.0.ebuild')
-rw-r--r--dev-ruby/amqp/amqp-1.8.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-ruby/amqp/amqp-1.8.0.ebuild b/dev-ruby/amqp/amqp-1.8.0.ebuild
new file mode 100644
index 000000000000..db2b2e7889d7
--- /dev/null
+++ b/dev-ruby/amqp/amqp-1.8.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby22 ruby23"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="ChangeLog.md README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit versionator ruby-fakegem
+
+DESCRIPTION="AMQP client implementation in Ruby/EventMachine"
+HOMEPAGE="http://rubyamqp.info/"
+
+LICENSE="Ruby"
+SLOT="1.4"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/multi_json dev-ruby/evented-spec )"
+ruby_add_rdepend ">=dev-ruby/eventmachine-0.12.4
+ >=dev-ruby/amq-protocol-2.2.0:2"
+
+all_ruby_prepare() {
+ #rm Gemfile || die
+ sed -i -e '/[Bb]undler/ s:^:#:' -e '/effin_utf8/ s:^:#:' spec/spec_helper.rb || die
+
+ # Many specs require a live rabbit server, but only root can start
+ # an instance. Skip these specs for now.
+ rm -rf spec/integration spec/unit/amqp/connection_spec.rb || die
+}
+
+all_ruby_install() {
+ dodoc -r docs examples
+}