summaryrefslogtreecommitdiff
path: root/dev-ruby/amq-protocol
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/amq-protocol
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/amq-protocol')
-rw-r--r--dev-ruby/amq-protocol/Manifest5
-rw-r--r--dev-ruby/amq-protocol/amq-protocol-2.2.0.ebuild27
-rw-r--r--dev-ruby/amq-protocol/amq-protocol-2.3.0.ebuild27
-rw-r--r--dev-ruby/amq-protocol/metadata.xml11
4 files changed, 70 insertions, 0 deletions
diff --git a/dev-ruby/amq-protocol/Manifest b/dev-ruby/amq-protocol/Manifest
new file mode 100644
index 000000000000..737cc2029a4d
--- /dev/null
+++ b/dev-ruby/amq-protocol/Manifest
@@ -0,0 +1,5 @@
+DIST amq-protocol-2.2.0.gem 43520 BLAKE2B 7cc9d8550ec2bfb40f4ad64f1baaeb782bda52562ccb6f7bb7692a1db400e1320e52c6ee10d0c1d3a96557fe4aa8f428e4f524e36b2a4c8685ca60b505fb3d9a SHA512 8637e7c1b2540edd57d9d06f5cf51430ff2ed4cd603e3b8a9f9c48dce2468452a4d365782ba949b7e007d773febe83c1a22bca2dafb21c24b3c8f655eb53e5b4
+DIST amq-protocol-2.3.0.gem 45568 BLAKE2B f5af9184a37bb7484e18765cf6bd807048339f44ece70a1c5dc8d6580eb1449bd1deda9bd467970c0d03088f4f666ef0ba59141fe90b335508a854440cc5dae4 SHA512 cb9ca136908f09dd7f38f763b87516379efafb2cc3dfe34268064c08ee9fdda8e9299de4d94b70aa0569362fe18a541287a6b9649383ee0720f199fdc0b75263
+EBUILD amq-protocol-2.2.0.ebuild 630 BLAKE2B 2a2ee4777165f13f95274f063110b5e4d977d1b045b29bab2e49d7a38e23f4fe59e5a71ad385f7a12f22df9575d21679714b4f0bb3c05976f55cda254d8e317f SHA512 cdc140bfb73cb0d9ab312e2ce12d32244db637c28cb0209348b6d90b7b02d1f62b7853562bba005b1eb212956b395ecabdfb25125209d77e96357d6e9eaf29cd
+EBUILD amq-protocol-2.3.0.ebuild 670 BLAKE2B 61ce7b08ba431cedf85f7215c2fa1f94fde10eaa0b0432f6ee5a0dc2cb7202e6180f9ad5f6a341afa509cb7b32ded3ccd9047665adad436e2e0727514165e2a4 SHA512 9c51ec463088e88886147aca7c0e8771422b14794f842f5d2390dd7244dc70567cbe49312c68f399b0192deba7f75b66fc258209f0ce1fd66a1957549aff0b68
+MISC metadata.xml 348 BLAKE2B ad178aa788b27c4acf67ab9e2e02b521e5b4def2669edc7a09b230b05e0876b2624b8039a9d715b92b6304338ab7cbbd0e73cf68b894199112c060f3b27ab55e SHA512 40807ab72ba61b47ebfe9e79363ec67c1237c8aae654f217fecfc8f78f7c77a6f099a535992213f128ce526e355405092d826612000511177ed784698b338a6e
diff --git a/dev-ruby/amq-protocol/amq-protocol-2.2.0.ebuild b/dev-ruby/amq-protocol/amq-protocol-2.2.0.ebuild
new file mode 100644
index 000000000000..0d03e29cb04b
--- /dev/null
+++ b/dev-ruby/amq-protocol/amq-protocol-2.2.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="ChangeLog.md README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An AMQP 0.9.1 serialization library for Ruby"
+HOMEPAGE="https://github.com/ruby-amqp/amq-protocol"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/rspec-its )"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -i -e '/bundler/ s:^:#:' -e '/effin_utf8/ s:^:#:' spec/spec_helper.rb || die
+}
diff --git a/dev-ruby/amq-protocol/amq-protocol-2.3.0.ebuild b/dev-ruby/amq-protocol/amq-protocol-2.3.0.ebuild
new file mode 100644
index 000000000000..3b0603c9a1c9
--- /dev/null
+++ b/dev-ruby/amq-protocol/amq-protocol-2.3.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="ChangeLog.md README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An AMQP 0.9.1 serialization library for Ruby"
+HOMEPAGE="https://github.com/ruby-amqp/amq-protocol"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/bundler dev-ruby/rspec-its )"
+
+all_ruby_prepare() {
+ sed -i -e '/\(simplecov\|effin_utf8\|byebug\)/ s:^:#:' Gemfile || die
+ sed -i -e '/effin_utf8/ s:^:#:' spec/spec_helper.rb || die
+}
diff --git a/dev-ruby/amq-protocol/metadata.xml b/dev-ruby/amq-protocol/metadata.xml
new file mode 100644
index 000000000000..61cfd235b7ab
--- /dev/null
+++ b/dev-ruby/amq-protocol/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ruby-amqp/amq-protocol</remote-id>
+ </upstream>
+</pkgmetadata>