summaryrefslogtreecommitdiff
path: root/dev-ruby/addressable
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/addressable
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/addressable')
-rw-r--r--dev-ruby/addressable/Manifest3
-rw-r--r--dev-ruby/addressable/addressable-2.5.2.ebuild43
-rw-r--r--dev-ruby/addressable/metadata.xml12
3 files changed, 58 insertions, 0 deletions
diff --git a/dev-ruby/addressable/Manifest b/dev-ruby/addressable/Manifest
new file mode 100644
index 000000000000..60c3978b1a89
--- /dev/null
+++ b/dev-ruby/addressable/Manifest
@@ -0,0 +1,3 @@
+DIST addressable-2.5.2.gem 103936 BLAKE2B c6677a2b5e9a7a1b279b2e3f1816cda40c0797254970ecaed2350d4d4739dee5a51580a8e2f94fc6bb87b9fe2a535d0a68b62eb672f8e91ff4da02e15e8dffcc SHA512 ddd5aeb4b241efa897a636fd85bd227bd5c6a8ae56129b6bbbdfaad85cdbb74e3d0db4bb6693f7df148b66f68ca1f557ac17a1fb0ea7698d25d883ab0b690bc4
+EBUILD addressable-2.5.2.ebuild 1350 BLAKE2B 7eefb341d4d789de27ac8d9711813764c2c733b8861d8a47a203cdee967281f3f359ee54c9ef612bb3b9b56640dc1cf3f4b1d056982a8ca34f1258872eb5beb9 SHA512 d996e82ed00fb02c139ca3ddba53f54c018568716d3cf9cdc8648028e9ae988efef15c2f4bf33e29069987170f281b395c3b3aa2a424b75c5e6ba1b1c70ab604
+MISC metadata.xml 404 BLAKE2B 4362f3592286dd6cffae99340e1b4437af10ab4dbbe44585d3370b0970e7d02a881853329c9412bfc881c3f040995a204b758aead2c34cba4f9df8104f858479 SHA512 c335566562492b85e491233d4f908fe18c2713ed9ac3afe2cb4d9537d71bdfa1a10bf58f1ca9f29e5a695fde9a4ba0ff9b3c57122afe78907cc0b00b5c307351
diff --git a/dev-ruby/addressable/addressable-2.5.2.ebuild b/dev-ruby/addressable/addressable-2.5.2.ebuild
new file mode 100644
index 000000000000..38a23114a753
--- /dev/null
+++ b/dev-ruby/addressable/addressable-2.5.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A replacement for the URI implementation that is part of Ruby's standard library"
+HOMEPAGE="https://rubygems.org/gems/addressable https://github.com/sporkmonger/addressable"
+
+LICENSE="Apache-2.0"
+
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+
+ruby_add_rdepend ">=dev-ruby/public_suffix-2.0.2:* <dev-ruby/public_suffix-4:*"
+
+ruby_add_bdepend "test? ( dev-ruby/rspec-its )"
+
+all_ruby_prepare() {
+ # Remove spec-related tasks so that we don't need to require rspec
+ # just to build the documentation, bug 383611.
+ sed -i -e '/spectask/d' Rakefile || die
+ rm -f tasks/rspec.rake || die
+ sed -i -e '/bundler/ s:^:#:' \
+ -e '/^begin/,/^end/ s:^:#:' \
+ spec/spec_helper.rb || die
+
+ # Remove specs requiring network connectivity
+ rm -f spec/addressable/net_http_compat_spec.rb || die
+
+ # Remove spec that tests against an unreleased github fork
+ rm -f spec/addressable/rack_mount_compat_spec.rb || die
+}
diff --git a/dev-ruby/addressable/metadata.xml b/dev-ruby/addressable/metadata.xml
new file mode 100644
index 000000000000..bc89c827d646
--- /dev/null
+++ b/dev-ruby/addressable/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">sporkmonger/addressable</remote-id>
+ <remote-id type="rubygems">addressable</remote-id>
+ </upstream>
+</pkgmetadata>