summaryrefslogtreecommitdiff
path: root/dev-ruby/addressable/addressable-2.8.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-29 15:53:38 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-03-29 15:53:38 +0100
commit822a054dd1bab7f8080ccd486398034b4ff0b97d (patch)
treec64bfd54aca68af69ccf06b1a9d20365383e3ccc /dev-ruby/addressable/addressable-2.8.0.ebuild
parentf7436a5ce1c11f1c33cd09dd757f768cd07b19fd (diff)
gentoo auto-resync : 29:03:2023 - 15:53:38
Diffstat (limited to 'dev-ruby/addressable/addressable-2.8.0.ebuild')
-rw-r--r--dev-ruby/addressable/addressable-2.8.0.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/dev-ruby/addressable/addressable-2.8.0.ebuild b/dev-ruby/addressable/addressable-2.8.0.ebuild
deleted file mode 100644
index 30f1e7b2d1f7..000000000000
--- a/dev-ruby/addressable/addressable-2.8.0.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-USE_RUBY="ruby26 ruby27 ruby30 ruby31"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md"
-
-RUBY_FAKEGEM_EXTRAINSTALL="data"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A replacement for the URI implementation that is part of Ruby's standard library"
-HOMEPAGE="https://rubygems.org/gems/addressable https://github.com/sporkmonger/addressable"
-
-LICENSE="Apache-2.0"
-
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~hppa ~loong ppc ppc64 ~riscv ~s390 ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris ~x86-solaris"
-IUSE="doc test"
-
-ruby_add_rdepend "dev-ruby/public_suffix:4"
-
-ruby_add_bdepend "test? ( dev-ruby/rspec-its )"
-
-all_ruby_prepare() {
- # Remove spec-related tasks so that we don't need to require rspec
- # just to build the documentation, bug 383611.
- sed -i -e '/spectask/d' Rakefile || die
- rm -f tasks/rspec.rake || die
- sed -i -e '/bundler/ s:^:#:' \
- -e '/^begin/,/^end/ s:^:#:' \
- spec/spec_helper.rb || die
-
- # Remove specs requiring network connectivity
- rm -f spec/addressable/net_http_compat_spec.rb || die
-
- # Remove spec that tests against an unreleased github fork
- rm -f spec/addressable/rack_mount_compat_spec.rb || die
-}