summaryrefslogtreecommitdiff
path: root/dev-ruby/activemodel/activemodel-7.1.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-21 14:09:19 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-21 14:09:19 +0000
commitabf4414edcea5e56092faea23c24176d361c2900 (patch)
tree499629ff3a8b3f107ed29b867af194f16e3498b8 /dev-ruby/activemodel/activemodel-7.1.3.ebuild
parent5adb1b3ff590f0911922679849a7fdacc8b4f217 (diff)
gentoo auto-resync : 21:01:2024 - 14:09:19
Diffstat (limited to 'dev-ruby/activemodel/activemodel-7.1.3.ebuild')
-rw-r--r--dev-ruby/activemodel/activemodel-7.1.3.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-ruby/activemodel/activemodel-7.1.3.ebuild b/dev-ruby/activemodel/activemodel-7.1.3.ebuild
new file mode 100644
index 000000000000..fe693d973eaa
--- /dev/null
+++ b/dev-ruby/activemodel/activemodel-7.1.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activemodel.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Toolkit for building modeling frameworks like Active Record and Active Resource"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="test"
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/activesupport-${PV}:*
+"
+
+ruby_add_bdepend "
+ test? (
+ ~dev-ruby/railties-${PV}
+ dev-ruby/test-unit:2
+ dev-ruby/mocha
+ >=dev-ruby/bcrypt-ruby-3.1.7
+ <dev-ruby/minitest-5.16:*
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ sed -i -e '/load_paths/d' test/cases/helper.rb || die "Unable to remove load paths"
+}