summaryrefslogtreecommitdiff
path: root/dev-ruby/activejob/activejob-6.1.7.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-19 15:38:48 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-19 15:38:48 +0100
commit3b882b15eed3bb219b5f340b63733c8cda643079 (patch)
treec84890953bd9a939137323d667a7762da89f0f0c /dev-ruby/activejob/activejob-6.1.7.3.ebuild
parent4d9aef45678c7cb55b24107642790224ab8c153b (diff)
gentoo auto-resync : 19:08:2023 - 15:38:48
Diffstat (limited to 'dev-ruby/activejob/activejob-6.1.7.3.ebuild')
-rw-r--r--dev-ruby/activejob/activejob-6.1.7.3.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/dev-ruby/activejob/activejob-6.1.7.3.ebuild b/dev-ruby/activejob/activejob-6.1.7.3.ebuild
deleted file mode 100644
index 897c76f82394..000000000000
--- a/dev-ruby/activejob/activejob-6.1.7.3.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-USE_RUBY="ruby27 ruby30 ruby31"
-
-RUBY_FAKEGEM_RECIPE_DOC=""
-RUBY_FAKEGEM_DOCDIR=""
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-
-RUBY_FAKEGEM_BINWRAP=""
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-RUBY_FAKEGEM_TASK_TEST="MT_NO_PLUGINS=1 test"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Job framework with pluggable queues"
-HOMEPAGE="https://github.com/rails/rails"
-SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="$(ver_cut 1-2)"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
-IUSE=""
-
-RUBY_S="rails-${PV}/${PN}"
-
-ruby_add_rdepend "
- ~dev-ruby/activesupport-${PV}
- >=dev-ruby/globalid-0.3.6
-"
-
-ruby_add_bdepend "
- test? (
- dev-ruby/mocha
- )"
-
-all_ruby_prepare() {
- sed -i -e '2igem "activesupport", "~> 6.1.0"' test/helper.rb || die
-
- # Remove all currently unpackaged queues.
- sed -i -e 's/que queue_classic resque sidekiq sneakers sucker_punch backburner//' \
- -e 's/delayed_job//' Rakefile || die
- sed -i -e '/SneakersAdapter/ s:^:#:' test/cases/exceptions_test.rb || die
-}