summaryrefslogtreecommitdiff
path: root/dev-ruby/activejob/activejob-6.0.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-02 19:13:18 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-02 19:13:18 +0100
commiteb2235d914984bff74c625de4fa4887d4f86f971 (patch)
treeec2a404a3e934f61b39cb264645bd763ece11503 /dev-ruby/activejob/activejob-6.0.6.ebuild
parentb0378783c1929d283116fe183089c123dba5869c (diff)
gentoo auto-resync : 02:10:2022 - 19:13:17
Diffstat (limited to 'dev-ruby/activejob/activejob-6.0.6.ebuild')
-rw-r--r--dev-ruby/activejob/activejob-6.0.6.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-ruby/activejob/activejob-6.0.6.ebuild b/dev-ruby/activejob/activejob-6.0.6.ebuild
new file mode 100644
index 000000000000..363725f7d849
--- /dev/null
+++ b/dev-ruby/activejob/activejob-6.0.6.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby27 ruby30"
+
+RUBY_FAKEGEM_RECIPE_DOC=""
+RUBY_FAKEGEM_DOCDIR=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Job framework with pluggable queues"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/globalid-0.3.6
+"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/mocha
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ sed -i -e '/load_paths/d' test/helper.rb || die "Unable to remove load paths"
+ sed -i -e '2igem "railties", "~> 6.0.0"' test/helper.rb || die
+
+ # Remove all currently unpackaged queues.
+ sed -i -e 's/que queue_classic resque sidekiq sneakers sucker_punch backburner//' \
+ -e 's/delayed_job//' Rakefile || die
+ sed -i -e '/SneakersAdapter/ s:^:#:' test/cases/exceptions_test.rb || die
+}