summaryrefslogtreecommitdiff
path: root/dev-ruby/activejob/activejob-6.0.5.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-10 17:37:15 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-10 17:37:15 +0100
commitc7c8d625ecbe5f95c445995303ed9b0e1f0de507 (patch)
treef0e6e5b3d8a377cf309b6085c2c7a30e640f84a1 /dev-ruby/activejob/activejob-6.0.5.1.ebuild
parentd6fe3a53bdeea6b060d1755199cc2c27492dc14c (diff)
gentoo auto-resync : 10:04:2023 - 17:37:14
Diffstat (limited to 'dev-ruby/activejob/activejob-6.0.5.1.ebuild')
-rw-r--r--dev-ruby/activejob/activejob-6.0.5.1.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/dev-ruby/activejob/activejob-6.0.5.1.ebuild b/dev-ruby/activejob/activejob-6.0.5.1.ebuild
deleted file mode 100644
index 3b04e888c93e..000000000000
--- a/dev-ruby/activejob/activejob-6.0.5.1.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-USE_RUBY="ruby26 ruby27 ruby30"
-
-RUBY_FAKEGEM_RECIPE_DOC=""
-RUBY_FAKEGEM_DOCDIR=""
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-
-RUBY_FAKEGEM_BINWRAP=""
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Job framework with pluggable queues"
-HOMEPAGE="https://github.com/rails/rails"
-SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="$(ver_cut 1-2)"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
-IUSE=""
-
-RUBY_S="rails-${PV}/${PN}"
-
-ruby_add_rdepend "
- ~dev-ruby/activesupport-${PV}
- >=dev-ruby/globalid-0.3.6
-"
-
-ruby_add_bdepend "
- test? (
- dev-ruby/mocha
- )"
-
-all_ruby_prepare() {
- # Set test environment to our hand.
- sed -i -e '/load_paths/d' test/helper.rb || die "Unable to remove load paths"
- sed -i -e '2igem "railties", "~> 6.0.0"' test/helper.rb || die
-
- # Remove all currently unpackaged queues.
- sed -i -e 's/que queue_classic resque sidekiq sneakers sucker_punch backburner//' \
- -e 's/delayed_job//' Rakefile || die
- sed -i -e '/SneakersAdapter/ s:^:#:' test/cases/exceptions_test.rb || die
-}