summaryrefslogtreecommitdiff
path: root/dev-ruby/actiontext
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /dev-ruby/actiontext
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'dev-ruby/actiontext')
-rw-r--r--dev-ruby/actiontext/Manifest2
-rw-r--r--dev-ruby/actiontext/actiontext-6.0.3.3.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-ruby/actiontext/Manifest b/dev-ruby/actiontext/Manifest
index 219a8775505b..cf7e6965cc06 100644
--- a/dev-ruby/actiontext/Manifest
+++ b/dev-ruby/actiontext/Manifest
@@ -1,3 +1,5 @@
DIST rails-6.0.3.2.tgz 18568792 BLAKE2B 574d4b7da1bf0ff308ca1a64369c16e29396c8faddf741bc0f2b7d0c0761e440d64dade6ef67ba4923045c7eab1cd0689d45b6b26f3e3077020157a2b29fb17f SHA512 ea019bef7facc1b8b0d2f181da45d70456a895f2d57eb2410e4a06ba7bea0165dacc0f15fe5080150e4b4ef3c81dacee70b200468232da857fdf60def85b5aec
+DIST rails-6.0.3.3.tgz 18569231 BLAKE2B 6e3e90433d655768a8d4da7824178e61bfeeb4645ae77f5e50c0e4859bcbad1f9cbc9391d3ab78ca15be096372abae1085e3e68ea9065cb76ec3c8fa0b12f50b SHA512 750a66613dce04058bb787479be2794b5e20879170640862d1ae3ac12faf3e2b6d7e9b536bdd1e94a2f4934f759228179c4e6f21dfccf6d7461fce9d9bd13892
EBUILD actiontext-6.0.3.2.ebuild 1632 BLAKE2B 44123592c0926e9d0b5d55bf9219c7770eeb4f4261a62b5ae138b21f351694204ee46e53c4875342475d45edba1d2a5561308b94df3175cf31b3f1433ee593ec SHA512 3488b55a41431d365ccfc6aeb2715effc81ddf0981cdb5d8989f22e2dd8ccbe6c21bb8fb15624e56a8d452bbc82b37f143184e2cd1cfd2d7090b59c838ad6cf4
+EBUILD actiontext-6.0.3.3.ebuild 1642 BLAKE2B c6d75fd93ea23b5c85fc64c39f1cdb8376ad23a703c8f56b07bbee10caadb819b759bdf08ef6ed47c49b551ae16ac8503f570c6d6251140e2996e8dead9e9aad SHA512 4804d398c10fcf4e9ee4698c55daecd5c58e940211589c68d0c4a2d008b83329878edf6872115bc480200b2ac9b277c782bfb7e0ff9e9c894f944bf093443235
MISC metadata.xml 337 BLAKE2B f2b57aeb9ea63b3cba576df9bed58bc86577ddfb1707d3a183a8536c71c797aca25ca61b22eb50ea54368fac052518f889db0503b816767e05978c803e204351 SHA512 ad52f0a3bf101472aa80ce4b516349ac090620aba4afecde872585bf1ff11f55cffaf762df123910a16d70aaf67ef59dcbdec728816f611a2d5bde90d2b6d09f
diff --git a/dev-ruby/actiontext/actiontext-6.0.3.3.ebuild b/dev-ruby/actiontext/actiontext-6.0.3.3.ebuild
new file mode 100644
index 000000000000..49794bec3489
--- /dev/null
+++ b/dev-ruby/actiontext/actiontext-6.0.3.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="actiontext.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRAINSTALL="app db package.json"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Edit and display rich text in Rails applications"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/actionpack-${PV}
+ ~dev-ruby/activerecord-${PV}
+ ~dev-ruby/activestorage-${PV}
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/nokogiri-1.8.5
+"
+
+ruby_add_bdepend "test? (
+ dev-ruby/mocha
+)"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|'mysql'\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|sprockets\|stackprof\|websocket-client-simple\|libxml-ruby\|redis\|blade\|aws-sdk\|google-cloud\|azure-storage\|selenium\|webdrivers\|minitest-bisect\|minitest-retry\|minitest-reporters\|listen\|rack-cache\|bootsnap\)/ s:^:#:" \
+ -e '/:job/,/end/ s:^:#:' \
+ -e '/group :doc/,/^end/ s:^:#:' ../Gemfile || die
+ rm ../Gemfile.lock || die
+}
+
+each_ruby_prepare() {
+ sed -i -e 's:ruby:'${RUBY}':' test/dummy/bin/* || die
+}