summaryrefslogtreecommitdiff
path: root/dev-ruby/actiontext
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-17 17:57:35 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-17 17:57:35 +0100
commit7932d472a02d4c016ff7dff4b7a5479ab9d1883d (patch)
treed07709230f82777cae6ba7dab35aee31896060fb /dev-ruby/actiontext
parentd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (diff)
gentoo resync : 17.06.2021
Diffstat (limited to 'dev-ruby/actiontext')
-rw-r--r--dev-ruby/actiontext/Manifest2
-rw-r--r--dev-ruby/actiontext/actiontext-6.0.4.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-ruby/actiontext/Manifest b/dev-ruby/actiontext/Manifest
index f11d913e6189..d293d317c7e0 100644
--- a/dev-ruby/actiontext/Manifest
+++ b/dev-ruby/actiontext/Manifest
@@ -1,5 +1,7 @@
DIST rails-6.0.3.7.tgz 18570545 BLAKE2B 6433705f18075e286d14d25dd87def61a3ac9c7a8fc5160f37b9a6f6ab0d7f36a7235602713888df45e55cf4afb56f922c476989304397d422016dc34f147353 SHA512 91612223c9461731741c056a700879ce274a177737fd19ed6341ce07acfa4e4862728ef12bfa1a70cdb3e5c8492ad0da6aae2e7d0ed5ad32d680d8bd8c3ab102
+DIST rails-6.0.4.tgz 18594882 BLAKE2B e24ede90a572bc5ebd8244f45b987a62d50080af38e7e8b1689b9af88b66e194c0c3859e35ec2efbd306fc0c2f62a9d8aaa669fb73ddedd940c23aabc2719c2e SHA512 5a9a050ea44716cf72985643098a08716d191fe08d2cf4404fdf80709340c68d4ca083929c7118dad2532cc64a96c28e5dee3ac9541c10745d0f9d0583eda685
DIST rails-6.1.3.2.tgz 10992572 BLAKE2B ec4b7c33180ecc6b9dc9bd0270c9c03e48a774a7c0fc1d79638bd6b52a4c9831f59c5d8714e24c9611ac9e8ad03dddc664c2969da8be568eade76464c04d5697 SHA512 3b30facfe0555c3161b5fc50efb7dc1f3df0eeadbfa19f16df3ebdb4877d6fb9a978ae7a6713a502d79e6d8f1be20157bd5ef64919fdd558cad89492cc2d9672
EBUILD actiontext-6.0.3.7.ebuild 1711 BLAKE2B 619a52854c7a3403284f7d89a5fcf50b2a9177f769d411ffaebfd0f89c8d07f49cde8aa48733716e294d57f60ab71b5b789eac0a7d56fcddda11c0e5e3b901d7 SHA512 52a7dfca2f53467b2b4ae19a31980d8d606de0716703976cdc98ea57a54e5e25b221941eb8953c0b4712c4c66d433734f2b40d3a3acc8c6a378338294118cb1e
+EBUILD actiontext-6.0.4.ebuild 1711 BLAKE2B 619a52854c7a3403284f7d89a5fcf50b2a9177f769d411ffaebfd0f89c8d07f49cde8aa48733716e294d57f60ab71b5b789eac0a7d56fcddda11c0e5e3b901d7 SHA512 52a7dfca2f53467b2b4ae19a31980d8d606de0716703976cdc98ea57a54e5e25b221941eb8953c0b4712c4c66d433734f2b40d3a3acc8c6a378338294118cb1e
EBUILD actiontext-6.1.3.2.ebuild 1705 BLAKE2B 8bdd8ef80c9820a3d32265d22825fa5aef29be8fae510e2e8330a10a0ebb9cbd1a0c2e53fbbfd9938f429fa2dbb1922cad84d6e210bba79cd7ea3a8c2e959b71 SHA512 57816a85a7751538342ebd97ec1bdf9fcd2d466e915daff604517953e9b64e274600d5fe1d2e2d822763c1853b8b9acbe30d7883e52ad89575362fc21732e842
MISC metadata.xml 337 BLAKE2B f2b57aeb9ea63b3cba576df9bed58bc86577ddfb1707d3a183a8536c71c797aca25ca61b22eb50ea54368fac052518f889db0503b816767e05978c803e204351 SHA512 ad52f0a3bf101472aa80ce4b516349ac090620aba4afecde872585bf1ff11f55cffaf762df123910a16d70aaf67ef59dcbdec728816f611a2d5bde90d2b6d09f
diff --git a/dev-ruby/actiontext/actiontext-6.0.4.ebuild b/dev-ruby/actiontext/actiontext-6.0.4.ebuild
new file mode 100644
index 000000000000..f9de1b021062
--- /dev/null
+++ b/dev-ruby/actiontext/actiontext-6.0.4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="actiontext.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRAINSTALL="app db package.json"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Edit and display rich text in Rails applications"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/actionpack-${PV}
+ ~dev-ruby/activerecord-${PV}
+ ~dev-ruby/activestorage-${PV}
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/nokogiri-1.8.5
+"
+
+ruby_add_bdepend "test? (
+ dev-ruby/mocha
+)"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|sass-rails\|webpacker\|rubocop\|'mysql'\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|sprockets\|stackprof\|websocket-client-simple\|libxml-ruby\|redis\|blade\|aws-sdk\|google-cloud\|azure-storage\|selenium\|webdrivers\|minitest-bisect\|minitest-retry\|minitest-reporters\|listen\|rack-cache\|bootsnap\|capybara\|byebug\)/ s:^:#:" \
+ -e '/:job/,/end/ s:^:#:' \
+ -e '/group :doc/,/^end/ s:^:#:' ../Gemfile || die
+ rm ../Gemfile.lock || die
+}
+
+each_ruby_prepare() {
+ sed -i -e 's:ruby:'${RUBY}':' test/dummy/bin/* || die
+}