summaryrefslogtreecommitdiff
path: root/dev-ruby/actiontext
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-10 13:21:36 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-10 13:21:36 +0000
commit77398e424e45d9e98c1cef3c43bdadb9d56e81ef (patch)
tree5aeffd3fc7b92fc615bd2c222fa8831aeda1925b /dev-ruby/actiontext
parentbd4aeefe33e63f613512604e47bfca7b2187697d (diff)
gentoo resync : 10.11.2019
Diffstat (limited to 'dev-ruby/actiontext')
-rw-r--r--dev-ruby/actiontext/Manifest2
-rw-r--r--dev-ruby/actiontext/actiontext-6.0.1.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-ruby/actiontext/Manifest b/dev-ruby/actiontext/Manifest
index 79c4a62f6a15..21d61c4127c9 100644
--- a/dev-ruby/actiontext/Manifest
+++ b/dev-ruby/actiontext/Manifest
@@ -1,3 +1,5 @@
DIST rails-6.0.0.tgz 18543484 BLAKE2B 614e71481a3a5ece629f49d0ef623b5352e165b5d46a736ccb747614d6c1fd56d4aaba2f2f32d48d81772cfd4db671d94a67cd3ffa395f29bf2de1f148fa57ed SHA512 3a2259fe2b3ffd0ddc9128e1aa58af57006b8410120a3629926b95fbe60b8658edab77929e26d9323c61a1855a4379e73f1ddbe875324b068a9e8bdde6ca55e6
+DIST rails-6.0.1.tgz 18551750 BLAKE2B 03349639ae114b82573e5e4063600b07b24274a0f5a81021bf347c650214e0f59fbb1676b9ad580de5a2d6e4dc85cc2702511c32d11a088ef663f26d8d55041e SHA512 ad6667a958663a8d260896c6b7fd589b657383f0d4f217c9bc0e993d6eac67c32fa41d54a9edf9b1f4e01ae78826f49a862b0069d59b3c1de2b950522b3ecf10
EBUILD actiontext-6.0.0.ebuild 1612 BLAKE2B da5e3efc4467a12d857c661737205adf0129c75c274492e7e10aa3e0a654be5c33b63d78e9154a200e2ab3e966f3f4391a338c37446443a343bf391ee3adbdb1 SHA512 02f906033420e1cce9abb220d4f63c6bb30155f5388fc6239cae36e69a8ca82182cb9dc8e43dbfd75b52846cb158e8c72cd27625d03357faa4487ab245a99924
+EBUILD actiontext-6.0.1.ebuild 1620 BLAKE2B f53f4df88aec8cd7f9a98ae625abd71af6a34d61e7656790b6b2a4d8400e1e2b6430fdbfd69c0cb2cc571f611701745752c88a8a005b76ca95fb7cad3c5ae792 SHA512 28dee316437ac7b17da63a264322a62c96e7280f515d5d5d75a0331969ccca6e9f20d75fdeeb4b1e40b80ae9b1be24b5b770a2c85c0bc7149818cff87357773c
MISC metadata.xml 337 BLAKE2B f2b57aeb9ea63b3cba576df9bed58bc86577ddfb1707d3a183a8536c71c797aca25ca61b22eb50ea54368fac052518f889db0503b816767e05978c803e204351 SHA512 ad52f0a3bf101472aa80ce4b516349ac090620aba4afecde872585bf1ff11f55cffaf762df123910a16d70aaf67ef59dcbdec728816f611a2d5bde90d2b6d09f
diff --git a/dev-ruby/actiontext/actiontext-6.0.1.ebuild b/dev-ruby/actiontext/actiontext-6.0.1.ebuild
new file mode 100644
index 000000000000..f06ed6e58aa4
--- /dev/null
+++ b/dev-ruby/actiontext/actiontext-6.0.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="actiontext.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRAINSTALL="app db package.json"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Edit and display rich text in Rails applications"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/actionpack-${PV}
+ ~dev-ruby/activerecord-${PV}
+ ~dev-ruby/activestorage-${PV}
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/nokogiri-1.8.5
+"
+
+ruby_add_bdepend "test? (
+ dev-ruby/mocha
+)"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|'mysql'\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|sprockets\|stackprof\|websocket-client-simple\|libxml-ruby\|redis\|blade\|aws-sdk\|google-cloud\|azure-storage\|selenium\|webdrivers\|minitest-bisect\|minitest-retry\|minitest-reporters\|listen\)/ s:^:#:" \
+ -e '/:job/,/end/ s:^:#:' \
+ -e '/group :doc/,/^end/ s:^:#:' ../Gemfile || die
+ rm ../Gemfile.lock || die
+}
+
+each_ruby_prepare() {
+ sed -i -e 's:ruby:'${RUBY}':' test/dummy/bin/* || die
+}