summaryrefslogtreecommitdiff
path: root/dev-ruby/actiontext/actiontext-6.1.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-10 17:37:15 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-10 17:37:15 +0100
commitc7c8d625ecbe5f95c445995303ed9b0e1f0de507 (patch)
treef0e6e5b3d8a377cf309b6085c2c7a30e640f84a1 /dev-ruby/actiontext/actiontext-6.1.7.ebuild
parentd6fe3a53bdeea6b060d1755199cc2c27492dc14c (diff)
gentoo auto-resync : 10:04:2023 - 17:37:14
Diffstat (limited to 'dev-ruby/actiontext/actiontext-6.1.7.ebuild')
-rw-r--r--dev-ruby/actiontext/actiontext-6.1.7.ebuild53
1 files changed, 0 insertions, 53 deletions
diff --git a/dev-ruby/actiontext/actiontext-6.1.7.ebuild b/dev-ruby/actiontext/actiontext-6.1.7.ebuild
deleted file mode 100644
index 213c623068e9..000000000000
--- a/dev-ruby/actiontext/actiontext-6.1.7.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-USE_RUBY="ruby27 ruby30"
-
-RUBY_FAKEGEM_RECIPE_DOC="none"
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-
-RUBY_FAKEGEM_GEMSPEC="actiontext.gemspec"
-
-RUBY_FAKEGEM_BINWRAP=""
-RUBY_FAKEGEM_EXTRAINSTALL="app db package.json"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Edit and display rich text in Rails applications"
-HOMEPAGE="https://github.com/rails/rails"
-SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="$(ver_cut 1-2)"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~riscv ~x86"
-IUSE=""
-
-RUBY_S="rails-${PV}/${PN}"
-
-ruby_add_rdepend "
- ~dev-ruby/actionpack-${PV}
- ~dev-ruby/activerecord-${PV}
- ~dev-ruby/activestorage-${PV}
- ~dev-ruby/activesupport-${PV}
- >=dev-ruby/nokogiri-1.8.5
-"
-
-ruby_add_bdepend "test? (
- dev-ruby/bundler
- dev-ruby/mocha
-)"
-
-all_ruby_prepare() {
- # Remove items from the common Gemfile that we don't need for this
- # test run. This also requires handling some gemspecs.
- sed -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|mysql2\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|sass-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|sprockets\|stackprof\|websocket-client-simple\|libxml-ruby\|redis\|blade\|aws-sdk\|google-cloud\|azure-storage\|selenium\|webpacker\|webrick\|webmock\|webdrivers\|minitest-bisect\|minitest-retry\|minitest-reporters\|listen\|rack-cache\|bootsnap\|capybara\|dalli\|connection_pool\)/ s:^:#:" \
- -e '/:job/,/end/ s:^:#:' \
- -e '/group :\(cable\|doc\|rubocop\|storage\|test\)/,/^end/ s:^:#:' \
- -i ../Gemfile || die
- rm ../Gemfile.lock || die
-}
-
-each_ruby_prepare() {
- sed -i -e 's:ruby:'${RUBY}':' test/dummy/bin/* || die
-}