summaryrefslogtreecommitdiff
path: root/dev-ruby/actionpack
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-07 17:30:28 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-07 17:30:28 +0100
commitdebb2c431b40a6b4750a39956cc5fcfa5a4a6476 (patch)
tree5c5fceb399f1dddaf02d4d8da8f674106cede374 /dev-ruby/actionpack
parenta17b25a10359070f9527893d861369d378021aa9 (diff)
gentoo auto-resync : 07:04:2023 - 17:30:27
Diffstat (limited to 'dev-ruby/actionpack')
-rw-r--r--dev-ruby/actionpack/Manifest1
-rw-r--r--dev-ruby/actionpack/actionpack-7.0.4.3-r1.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-ruby/actionpack/Manifest b/dev-ruby/actionpack/Manifest
index 34bd067efe7a..ce59fc3ce35f 100644
--- a/dev-ruby/actionpack/Manifest
+++ b/dev-ruby/actionpack/Manifest
@@ -15,6 +15,7 @@ EBUILD actionpack-6.1.7.2.ebuild 2386 BLAKE2B 6a25a96da9b7527153b37014e5b4ffdc47
EBUILD actionpack-6.1.7.3.ebuild 2386 BLAKE2B 6a25a96da9b7527153b37014e5b4ffdc47d7eb07eb2a028eb1f5581943d000389bdf18dead08518f46610377db2f5b3ce169d6813ba52ed4e2df87d2910ee699 SHA512 49bfd6b5fe4d850eb2f745b31ee9e4ca06b41261cb6e7d9f367032bf5504ea37e4522ad50b9462c09b1b4647a036ab6270876085b1193897a39fc1ab60b4b473
EBUILD actionpack-6.1.7.ebuild 2313 BLAKE2B b4342277df329108394cc831444ef1e5cf9279a34eefc17df77e97e57e8bbe048cfadce7bfb74ae1a564f2ea43dfcc3e8a4eecc77416ba52fb29ae2215700676 SHA512 0edd62ebeef660d1479d41889505b3b60ad62fa5556d15eed299850306efa4eab1454db427143b8db7f58a1018240e14c4a98b32d185fe619b87625bdae5cfd7
EBUILD actionpack-7.0.4.2.ebuild 2184 BLAKE2B 852723d17227485f6f342c1b244997e62b176dcc91857ea68f2b3a3c63b5770e2e24de0b3fa08f407547cf3efa97f5791ddbd4d5aa429b0e5dd1c34f20b668be SHA512 120f1c635a451a9f72a7257aebddd21fd1cc0e5895c6576569fe0cd9646685122c8939ee2efa2b91f0f1ddd1e7807b4e2c68b31d5aa2a5eaa12b1073da9e9032
+EBUILD actionpack-7.0.4.3-r1.ebuild 2189 BLAKE2B 1c264485f84886b87a8c339941aeac8929997e43a626a0c56b9b7723f8a5a7fc07bcdd5cf6c23f601b3189777dc05a578977e13d4c33a97fa565025a15674b43 SHA512 6a6ea7371a26cc25a5df876ab9b2d050eea4fd49eb6a7e32266e8a08d0e304bc9d76496f8fcb64fbde9779aee1f7bb151af10ecd7a763323fdb3010c3cb66803
EBUILD actionpack-7.0.4.3.ebuild 2195 BLAKE2B edac1578c8c3bc57d9add70a1dfbef08cf79ed395f5623b842c3dd05038aa8dafdf83c53903f12ca7e58ecb49aab5cf75275a7da49be470c130561858a9850a6 SHA512 0cadc61f68791b9bca0cb4b6b7422737b7d46e39e129ae385819b4ac9fa266b311fa1b007a80ccc8a7429a52d783f9f9fb53ff161fc0df90b6db37e42f19e1a4
EBUILD actionpack-7.0.4.ebuild 2037 BLAKE2B b40fa610ca9223bf752a6c157b8293249da0d30089979d091c10eb0d0614bff754b98cd990131db0f19836196d079490f211d4c0a835b423148f00ce90c7841d SHA512 fe5b3db6bd2c24970a3bdfec13bdd1b56e71fdf56216f848a979569c3322054b6f91cfb9fa6993a1e2055390bf1f171c4665910d5faf9b65ed32ae29edacbd9e
MISC metadata.xml 338 BLAKE2B f32f1ecbd729e4e6162f22cdb9bfe1fbb1284c8b7f021d8207a1a54d2543b0e9866e775d550360dd01ef4f4eb92e96064a8416476c7047853034ea05479eb6e7 SHA512 24fd0d8ea6e3cd5514e5049b7e064b7e3e667ea14978cc7cf620e9c1b020bdc7caf7dbec97ccbf92c2f4c657fff3e9151d6f2af103b3d9c3cc5181cb3a81a295
diff --git a/dev-ruby/actionpack/actionpack-7.0.4.3-r1.ebuild b/dev-ruby/actionpack/actionpack-7.0.4.3-r1.ebuild
new file mode 100644
index 000000000000..1aefaa523fef
--- /dev/null
+++ b/dev-ruby/actionpack/actionpack-7.0.4.3-r1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="actionpack.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Eases web-request routing, handling, and response"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/activesupport-${PV}
+ ~dev-ruby/actionview-${PV}
+ dev-ruby/rack:2.2
+ >=dev-ruby/rack-test-0.6.3:*
+ >=dev-ruby/rails-html-sanitizer-1.2.0:1
+ dev-ruby/rails-dom-testing:2
+"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/mocha:0.14
+ dev-ruby/bundler
+ >=dev-ruby/capybara-2.15
+ ~dev-ruby/activemodel-${PV}
+ ~dev-ruby/railties-${PV}
+ >=dev-ruby/rack-cache-1.2:1.2
+ dev-ruby/selenium-webdriver:4
+ www-servers/puma
+ <dev-ruby/minitest-5.16:*
+ )"
+
+all_ruby_prepare() {
+ eapply "${FILESDIR}/actionpack-7.0.4-rack-test-2.patch"
+
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|'mysql'\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|sprockets\|stackprof\)/ s:^:#:" \
+ -e '/:job/,/end/ s:^:#:' \
+ -e '/group :doc/,/^end/ s:^:#:' ../Gemfile || die
+ rm ../Gemfile.lock || die
+
+ sed -i -e '1igem "rack", "<3"' test/abstract_unit.rb || die
+
+ # Use different timezone notation, this changed at some point due to an external dependency changing.
+ sed -i -e 's/-0000/GMT/' test/dispatch/response_test.rb test/dispatch/cookies_test.rb test/dispatch/session/cookie_store_test.rb || die
+
+ # Avoid tests that fail with a fixed cgi.rb version
+ sed -i -e '/test_session_store_with_all_domains/askip "Fails with fixed cgi.rb"' test/dispatch/session/cookie_store_test.rb || die
+}