summaryrefslogtreecommitdiff
path: root/dev-ruby/actionpack/actionpack-7.0.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-30 11:17:10 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-30 11:17:10 +0100
commit200338d9ebd0cd0599af59f208eb58f48f5ae168 (patch)
tree03aa7ba96612219b7aeb018639ba95924c0f1d81 /dev-ruby/actionpack/actionpack-7.0.4.ebuild
parenta9a8100d7a659b808e3a112a113b65e16f0070c3 (diff)
gentoo auto-resync : 30:04:2023 - 11:17:09
Diffstat (limited to 'dev-ruby/actionpack/actionpack-7.0.4.ebuild')
-rw-r--r--dev-ruby/actionpack/actionpack-7.0.4.ebuild66
1 files changed, 0 insertions, 66 deletions
diff --git a/dev-ruby/actionpack/actionpack-7.0.4.ebuild b/dev-ruby/actionpack/actionpack-7.0.4.ebuild
deleted file mode 100644
index 506da69e48ee..000000000000
--- a/dev-ruby/actionpack/actionpack-7.0.4.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-USE_RUBY="ruby27 ruby30 ruby31"
-
-RUBY_FAKEGEM_RECIPE_DOC="none"
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
-
-RUBY_FAKEGEM_GEMSPEC="actionpack.gemspec"
-
-RUBY_FAKEGEM_BINWRAP=""
-
-inherit ruby-fakegem
-
-DESCRIPTION="Eases web-request routing, handling, and response"
-HOMEPAGE="https://github.com/rails/rails"
-SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="$(ver_cut 1-2)"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
-IUSE=""
-
-RUBY_S="rails-${PV}/${PN}"
-
-ruby_add_rdepend "
- ~dev-ruby/activesupport-${PV}
- ~dev-ruby/actionview-${PV}
- dev-ruby/rack:2.2
- >=dev-ruby/rack-test-0.6.3:*
- >=dev-ruby/rails-html-sanitizer-1.2.0:1
- dev-ruby/rails-dom-testing:2
-"
-
-ruby_add_bdepend "
- test? (
- dev-ruby/mocha:0.14
- dev-ruby/bundler
- >=dev-ruby/capybara-2.15
- ~dev-ruby/activemodel-${PV}
- ~dev-ruby/railties-${PV}
- dev-ruby/selenium-webdriver:4
- www-servers/puma
- <dev-ruby/minitest-5.16:*
- )"
-
-all_ruby_prepare() {
- eapply "${FILESDIR}/${P}-rack-test-2.patch"
-
- # Remove items from the common Gemfile that we don't need for this
- # test run. This also requires handling some gemspecs.
- sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|'mysql'\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|sprockets\|stackprof\)/ s:^:#:" \
- -e '/:job/,/end/ s:^:#:' \
- -e '/group :doc/,/^end/ s:^:#:' ../Gemfile || die
- rm ../Gemfile.lock || die
-
- # Use different timezone notation, this changed at some point due to an external dependency changing.
- sed -i -e 's/-0000/GMT/' test/dispatch/response_test.rb test/dispatch/cookies_test.rb test/dispatch/session/cookie_store_test.rb || die
-
- # Avoid tests with rack-cache since it is not ready for ruby31
- # >=dev-ruby/rack-cache-1.2:1.2
- rm -f test/dispatch/rack_cache_test.rb || die
-}